0

I ran this command:

gem --version
1.3.5

I found it to be kind of strange since I didn't specify which gem I was asking about.

I am trying to install the rails gem like this:

gem install rails ERROR: Error installing rails: bundler requires RubyGems version >= 1.3.6

But I downloaded the latest gems version 1.7.2 but can't get it to be the system's default version. Any ideas how to manage this conflict?

1

Try

sudo gem update --system

to update rubygems to the latest version.

1

gem --version tells you the version of the RubyGems packaging system.

If you've installed a new version of RubyGems, it's probably been installed in a non-standard location. It didn't replace the old version of gem, and that version is still the one in your PATH. To run your version, execute it directly or put it in your PATH.

  • So is RubyGems a parallel product to RVM, and both are meant to help you manage your gems? – Genadinik Apr 21 '11 at 22:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.