I'm trying to set up a backuppc client using ssh+rsync via cygwin on Win 7. SSH was working fine. I added the backuppc user then used mkpasswd to add the user to /etc/passwd. Now ssh fails with:

Windows could not start the CYGWIN sshd service on Local Computer. Error 1069 the service did not start due to a logon failure.

These directories are huge and trying to use a standard copy process would suck. I will settle for robocopy but I'm curious as to how one can completely incapacitate a fully functional ssh service simply by adding a user to /etc/passwd.

Any idea how to get sshd running again? It's fallen like a deck of cards -- I've tried reconfiguring it with ssh-host-config ...reinstalling it. Nothing, nada -- fail.

1 Answer 1


Here's what worked in case someone else runs into this.

passwd cyg_server

The assumption is that you've run

ssh-host-config -y

To set up sshd, take the defaults. On Win 7 if you click on the CYGWIN sshd service then look at the logon tab, you'll note that Cygwin creates a cyg_server user to run sshd under. For some bizarre reason -- at some point, creating a new user and adding them to /etc/passwd screws up sshd. After you run the passwd command above, enter the password as prompted then make sure it matches the password field in the logon tab for the service properties. Start the CYGWIN sshd service. Can't take credit here -- I Googled it.

devshed - sshd logon error

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.