2

We recently went through an upgrade to Exchange 2010 and I've noticed that new distribution lists that have been created since the upgrade do not show up in the GAL.

Can somebody please tell me what I need to do to ensure these show up in the GAL?

The Outlook clients are in cached mode but they update the GAL every 24 hours and these distros still don't show up.

Thanks in advance.

1
  • Have you switched OAB creation to the new server?
    – Vick Vega
    Apr 25, 2011 at 18:39

4 Answers 4

2

While I was doing some testing of the old way (pure AD call) that we used to create DGs in E2k3, I found that once in a e2k10 environment there is a need to run the powershell command (Set-DistributionGroup) to update the DG specifically the property "HiddenFromAddressListsEnabled" with the appropriate value for it to show up in GAL. Of course when you run this command, you will be prompted to upgrade the DG which seems to be affecting some attributes (msExchangeVersion, showInAddressBook etc.).

1

I've solved the problem in the short term by adding values for "showInAddressBook" using ADSI Edit. However, I'd like to know how to set this up to be done automatically in Exchange 2010 for distributions lists like it was in Exchange 2003.

0

You must create the distribution group using the EMC otherwise if you do it from AD Users And Computers you still have to create from EMC for an existing Distribution Group (the one created created from ADUC)

0

I had a distribution group that was not been shown up in GAL, then from EMC->Recipient Configuration->Distribution Group, I double-clicked the problematic group and on the ADVCANCED tab I checked "Hide group from Exchange Address lists" then I was warned that the object version must be upgraded to current exchange version, I click YES and then unchecked it. Now the distribution group is listed on GAL either from OWA or from outlook clients.

I want to point out that I migrated from Exchange 2003 to 2010 several years ago and it seems some objects were not updated its version.

Hope this help

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .