I'm trying to deploy an MVC3 application to IIS 7.5 On every route I'm getting an http 500 - internal server error :

Error Summary
HTTP Error 500.0 - Internal Server Error
The page cannot be displayed because an internal server error has occurred. Detailed Error Information
Module ManagedPipelineHandler 
Notification ExecuteRequestHandler 
Handler System.Web.Mvc.MvcHandler 
Error Code 0x00000000 
Requested URL http://www.xxxxxx.com:80/Home/Index
Physical Path C:\inetpub\wwwroot\xxxxxx.com\Home\NoAccess 
Logon Method Anonymous 
Logon User Anonymous 
Failed Request Tracing Log Directory C:\inetpub ..

I am able to request simple html files, or regular aspx files with inline code. Failed request tracing was enabled and the request trace showed one warning :

ModuleName ManagedPipelineHandler 
Notification 128 
HttpStatus 500 
HttpReason Internal Server Error 
HttpSubStatus 0 
ErrorCode 0 
ErrorCode The operation completed successfully. (0x0) 

When I try to recreate the site in IIS, and test connection I'm getting a "Cannot verify access to path" error. I gave full control to the Network Service and the application pool's identity is also Network Service.

Framework is set to 4.0, managed pipeline mode = integrated.

Any Ideas .. or is more info needed?

  • Have you try to change it to classic mode? May 26 '11 at 6:22

Have a look here first: https://stackoverflow.com/questions/5349867/error-handling-in-asp-net-mvc3

Update: if it doesn't help - read this discussion (especially the last post on page 2): http://forums.asp.net/t/1657582.aspx/2/10?Error+500+0+when+MVC+runs+on+IIS7

Update 2: This one looks very promissing too: http://forums.asp.net/t/1652026.aspx/1

remove <add verb="POST,GET" path="ajax/*.ashx" type="Ajax.PageHandlerFactory, Ajax" /> from httpHandlers

and add <add verb="POST,GET" name="scripthandlerajaxFactory" path="ajax/*.ashx" type="Ajax.PageHandlerFactory, Ajax" /> to handlers

  • I don't think this helps me, the same error is shown in firefox, IE, Opera. And CustomErrors=Off in the web.config. Somehow MVC or the routing does not work.
    – redrobot
    Apr 27 '11 at 14:42
  • Ok. have a look at the 2nd URL. Exactly the scenario you describe.
    – DmitryK
    Apr 27 '11 at 14:48

Please check with the application, maybe that's intended behavior.

I've had exactly the same problem, checked all the obvious permissions (IIS APPPOOL\AppPoolName permission to filesystem and database, Authenticated Users access to "Scripts" and "Content" directoriues) and still no luck. Even Process Monitor did not help, there were no failed access logs.

The solution was simple - that 403.0 was proper response code. I believed that the web application should return a standard view saying "your domain account is not listed in the database, so go away" (as all apps in this project should, that's a convention we use). But for this one app, the developer made it different, and return plain 403.0, which IIS "decorated".


Had this after moving wwwroot folder from a backup. Had to add IIS_IUSRS to the folder permissions. https://stackoverflow.com/questions/14934006/iis-iusrs-and-iusr-permissions-in-iis8

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.