When I copy a file from the workstation to the server (uploading from the WS) the data transfer is very slow, not more than 1MB/s

Also, when I do the same operation but downloading the files from the server, the data transfer is a little bit faster, but not more than 2MB/s

But when I transfer a file from the server to the workstation (uploading or downloading from the server) the data transfer is ok, about 10MB/s

I think this issue is also messing with the print service, because its also very slow.

Some info about the server:

  • HP Proliant ML150 G6
  • 100Mbps network
  • Roles and services: AD-DC, DNS, AD-RMS, Exchange 2007 SP3, SQL 2008 R2, print and file server.

I've disabled the firewall, updated drivers, firmwares, BIOS. I've turned off IPv6, I've tried the following netsh commands that I found on Google.

netsh int tcp set global rss=disable
netsh int tcp set global autotuninglevel=disable
netsh int tcp set global chimney=disable

I've tried all those and reversed the changes because nothing worked.


I just installed the server 1 week ago, I remember that this problem was not bothering after installing AD-DC but before installing the exchange server 2K7... i dont remember after the E2k7 installation

After the E2k7 installation, I installed the AD-RMS role, thats when I realise the slowness of the system, and after installing the AD-RMS, I installed the SQL... so i guess the SQL isn't causing the problem.

I have had not the chance of test the transfer speed connecting the server and a WS directly, but I guess its gonna be the same slowness.

  • 2
    I'm not surprised it's running slow with all that on it! – Ben Pilbrow Apr 27 '11 at 22:43
  • 2
    And by the way, Exchange and SQL Server shouldn't be installed on a DC and I don't know how Exchange and SQL Server play together (probably not so well). That's not to say you can't, just shouldn't. – Ben Pilbrow Apr 27 '11 at 22:45
  • how much RAM in that box? – Chris S Apr 27 '11 at 23:12
  • This isn't an SBS box is it? If so, that many roles is not out of the ordinary. – DanBig Apr 28 '11 at 13:16
  • 4GB RAM, this is the standard version of WS2k8R2 – Daniel Schilling Apr 29 '11 at 4:32

With that many roles installed on the server I'd be setting up a shrine and praying that it doesn't fail.

Seriously though, With that many variables it would be really hard to determine what the slowness might be attributed to. Not to mention you don't say what other hardware sits between these two devices. Is the workstation a x64 bit OS? Does it have a 100mbps NIC?

If your workstation is XP I'd be interested to hear if you can replicate those speeds on a Vista/ 7 box. SMB 2.0 used in Server 2008 / Vista/ 7 should speed things up.

  • It may have a 100mb, or he may have a 100mb hub/switch, but that doesn't explain why he can transfer from the server at 10MB/s, but operations from the workstation are in the 1-2MB/s range. – Zoredache Apr 27 '11 at 23:27
  • hi, it doesnt matter what O.S., ive tried with w7 and wxp 32b. the WS and the server are connected with a 100Mbps switch, i've that many roles installed because its a small network, less than 20 workstations and 2 servers – Daniel Schilling Apr 29 '11 at 4:35

Have you verified if TCP Checksum Offloading is on? This can be found in the adapter's advanced properties (from the device manager) - this should be on, unless you have invalid packets frequently sent by the host.

  • Why would this apply only for operations from the client, and not when transfers are being initiated by the server? – Zoredache Apr 27 '11 at 23:28
  • i have not, ill check it tomorrow and see if that works, thanks! – Daniel Schilling Apr 29 '11 at 4:27
  • Hi, the TCP checksum offloading is on (TX and RX) – Daniel Schilling Apr 29 '11 at 23:14

SMB Signing is turned on by the AD-DC Role, is it not? That will incur a cryptographic penalty. It might also account for the asymmetry, in that a copy "from the server to the workstation" makes the workstation a "server" in the SMB sense and it won't have the signing policy enabled.

  • Hi, today i turned SMB Signing off with GPO then i make some tests but its the same transfer speed – Daniel Schilling Apr 29 '11 at 23:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.