I'm trying to install Win 2k3 Server on my new TYAN S5350 Motherboard. The controller is configured for a RAID 0 with 2x 500Gb Harddrives. I made a floppy disk with the drivers but it doesn't work: maybe the floppy disk drive is too old, I don't know. Is there any other possibility to make my Harddrive visible during the install of Windows 2003? Thanks.

Edit: Now I tried with an internal floppy disk drive (that I found somewhere in the basement!). It starts the drivers, but then a blue screen pops up just before loading windows harddrive configuration. The basic blue screen recommending a check disk. What is the matter?

  • Why would you install a server on a RAID0 array? Do you like downtime? – Evan Anderson Jun 23 '09 at 16:36
  • I just changed it to a RAID1. Actually slower, but safer, even if my system is already good backuped. – waszkiewicz Jun 25 '09 at 12:10
  • I have a feeling that this is not a server being used at a real business.. – pauska Jun 25 '09 at 14:13
  • "Real business"? It's funny how people can waste their time. Businees is real, and even making profits... but thanks for your concern. – waszkiewicz Jun 25 '09 at 20:54

You can use nlite to slipstream your driver in the installation CD. nlite is free and downloadable here: http://www.nliteos.com/

  • Merci Mathieu! I'll try it right away. – waszkiewicz Jun 16 '09 at 12:04
  • It doesn't work. I've integrated the driver in a new copy of Windows 2003 Server, but it's still asking for a floppy A: ! And if I continue without it, then the hard drives aren't recognized. – waszkiewicz Jun 16 '09 at 12:21
  • I've used nLite many times to do this with a variety of different controllers. If it's not working you have the wrong drivers! – John Rennie Jun 16 '09 at 13:51
  • Where did you get the driver from ? can i download it ? – Mathieu Chateau Jun 16 '09 at 13:51
  • Yeah. The driver comes from ftp.tyan.com/RAID/AdaptecASMBESoftware/Windows/Win860.zip. I think I did everything right with nLite (a very nice freeware by the way), but it's always the same problem: HDD not detected by Windows 2003 installation. – waszkiewicz Jun 16 '09 at 14:43

I'm a Linux/Unix guy, and I don't know if this applies there, but I remember a particular problem installing the driver for a RAID controller on WS2003 with an USB floppy drive : depending upon the drive make/model, the first stage of WS2003 installer loads the floppy correctly, but the second stage ( after the "starting up windows" message ) can't access the floppy drive and load the driver.

See for instance : installing WS2003 SP2 with an USB floppy.


I'm not trying to be flippant, but it sounds like you have the wrong driver.

  • I rated this up and the comment below, because the OP has to check both possibilities: Either the USB floppy isn't recognized (if he's using one, I haven't used Tyan boards like his so not sure if it has a floppy connector anymore) Or he has the wrong driver, which is probable given Tyan's poor documentation. – dmoisan Jun 23 '09 at 13:19
  • I tried almost all the other drivers from the website: none of them works. The floppy is recognize, cause I can hear it searching. – waszkiewicz Jun 25 '09 at 6:39
  • Or the wrong OS... Linux doesn't have this problem... – Tom O'Connor Jul 8 '10 at 7:26

Thanks for all your very helpfull tricks and hints. I just tried it the simplyest way: 1. I connected my floppy disk drive inside the server 2. I inserted the floppy with the right SATA/RAID driver in the drive. 3. I booted the Server using the original CD of Windows 2003 Server (not the on made with nLite) 4. Everything worked somehow.

For information: I know how to boot on a USB Floppy disk drive, or USB stick. I also updated the BIOS and made my ARRAY a few time to make sure I wasn't making something stupid! Anyway, merci Mathieu pour le petit programme, Nlite is a very nice software.


In addition to verifying Windows Server sees the floppy, you may need to check with Tyan support to verify the correct driver. I had an S3950 running WS 2003 at the time and had to contact them because they had the wrong driver on their website and I had a case open with them until they found it. Actually, I did some digging and found the third-party driver that it actually was, but Tyan eventually came back with the same information. RAID drivers != not necessarily SATA drivers.

I'm not sure what chipset your Tyan board is using, but I found out the RAID chipset vendor was sold to another party, which eventually let its support wither away so I ended up getting a RAID card anyway.


This may be stating the obvious, but make sure you download the driver to match the 32/64 bit version of Win 2003 you have. The link you posted was for the 32 bit version. Also on the driver page for your motherboard there is an 'Adaptec Option' RAID driver in addition to the one you downloaded. Have you tried this one as well?.

I cant add comments yet, but I would also agree that nlite is the easiest option to integrate the drivers.

  • Yes, I did try all the drivers for Tyan 5350 MB. I tried as well a Win2k3 installation CD with all of them on it-> didn't work either. – waszkiewicz Jun 25 '09 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.