We had an a Asp.Net 2 website setup for a client of ours some years ago which was working fine until a couple of days ago.

Here are the details:

  • Windows 2003 Sp1
  • 1 GB RAM
  • IIS 6.0

Suddently, IIS stopped serving any HTTP requests (including HTML files) even though FTP is working fine. Running a ping also returns a proper IP.

Stuff that I have tried:

  • Recycling the App Pool.
  • Restarting IIS
  • Uninstalling / Reinstalling IIS
  • Trying to setup a simple Hello World, single page HTML website

But none of this works. I keep getting the following message (in FF) while trying to access the site:

The connection to the server was reset while the page was loading. The site could be temporarily unavailable or too busy. Try again in a few moments. If you are unable to load any pages, check your computer's network connection. If your computer or network is protected by a firewall or proxy, make sure that Firefox is permitted to access the Web.

All the bindings are correct and point to the IP. Has this happened to anyone before and could anyone help me out here?



I forgot to mention these points earlier. - Rebooting the server has no effect on this. I have tried this multiple times. - There are no IIS logs from 21st April 2011. From when the site has been down. Even event logs for 21st / 22nd don't show anything out of the ordinary.

EDIT 2 I got this tool from the IIS Debug Toolkit called WFetch and ran it for localhost which had the default IIS website with a Hello page. Following is the response:

started.... WWWConnect::Connect("localhost","80")\n IP = ""\n source port: 1085\r\n WWWConnect::Close("localhost","80")\n closed source port: 1085\r\n cannot send data, because connection is closed finished.

EDIT 3 After almost 10 days of hell, IIS just started working automatically. Just like that. I had reinstalled it - but was getting the same issue even after reinstalling. However, we had given up all hope and started migrating to a new server when after 2 days of installing the damn thing started serving up pages again. Very weird and I have no idea what was going on.

Thanks to everyone for all their suggestions - they were of great learning and helpful in figuring out how to go about debugging IIS. Really appreciate it.

  • Have you checked the event log? Is there a firewall between your server and the internet? Any logs there? Can you access it locally?
    – Nixphoe
    Apr 30 '11 at 18:41
  • Have you tried rebooting the server?
    – joeqwerty
    Apr 30 '11 at 19:14
  • @Nixphoe: No firewall running and I cannot access it locally either. I get the same error when I try to access it via localhost or Thanks.
    – saurabhj
    Apr 30 '11 at 19:32
  • Check the Event Log on the server. Also run through the IIS log. Might check out this tool as well. iis.net/community/default.aspx?tabid=34&g=6&i=1864
    – Nixphoe
    May 1 '11 at 1:41
  • 1
    Anything interesting in the event logs after an IISReset? Perhaps a "can't bind to port" message from HTTP.SYS, or a WAS/W3ADM registration error? Also, there was a problem with some binaries and updates breaking IIS if the version was out of whack - you could try an SP2 upgrade to standardize all the binary versions (and get the server eligible for security updates again)
    – TristanK
    May 1 '11 at 2:49

Some troubleshooting steps to try are:

  • See if a static test.html page works
  • create a new site and app pool and see if it works
  • does the site show as started in IIS Manager. If it doesn't then there may be a duplicate binding.
  • Event Viewer immediately after an iisreset and first view is often very helpful
  • try a 'fail test', by stopping the website and seeing if the message is different. If it is then you know that the visit is hitting the correct site for sure. If it's not different than either the site completely fails right away, or something is off with the bindings, meaning that another site or server is handling the request
  • I haven't tried #5 and now I think it is too late to try it also. I had tried the other suggestions. Replies are: NO for #1 and #2. #3 - site shows as started and there is only the Default site running with only one binding. #4 - Event Viewer does not show anything of interest pertaining to the Web publishing / IIS service. Thank you very much for taking the time out to help me though. Really appreciate it.
    – saurabhj
    May 3 '11 at 5:07
  • Interesting that it just started working out of the blue, but I'm glad that it's working now. If it stops working again, feel free to add a comment to this thread and I'll see if I can help brainstorm further. May 3 '11 at 14:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.