I've searched Google and seen discussions on it, even on their own MS blogs but I'm at a loss.

I've gone into WSUS and chose all of the .NET Framework packages I can find (they were in the "Service Packs" area) and set them to "Install" for a test group.

However, when I look at the reports, all of those packages show as "N/A" for the computers in the test group. But the computers still only have the default .NET 1.1 installed.

So my real question is:

Can I deploy .NET Framework 3.5 through WSUS? If so, how? If not, can you recommend another SIMPLE way to deploy it (I say this because the steps to deploy it using GPO Software installs is a nightmare with tons of prereqs, etc.).



(first, other updates deploy just fine to these computers)

The .NET Framework I have set to install in WSUS is:


BAH...NEVERMIND...now when I go back in and run the report it shows as Installed. Last week it was showing as N/A. I guess I jumped the gun on the question.

  • You don't see .NET 3.5 with SP1 in WSUS? I was sure it was in there... let me check my WSUS server.
    – Andy May
    Commented Jun 16, 2009 at 14:03
  • Which KB# did you approve that is saying N/A? 951847?
    – Andy May
    Commented Jun 16, 2009 at 14:15
  • See my edits above in my Original post for the answers to your questions.
    – TheCleaner
    Commented Jun 16, 2009 at 18:44
  • Oh, and I'd have accepted your comment as the answer but can't...so if you post the KB article again in the answer I'll accept your answer.
    – TheCleaner
    Commented Jun 16, 2009 at 18:51

4 Answers 4


Check out this blog post (May 7, 2009):

.NET Framework 3.5 Service Pack 1 (SP1) and Family Update package revisions coming soon!

As alternative, you could deploy it using the Active Directory (.NET Framework 3.5 Deployment Guide for Administrators):

This section describes how to use Active Directory to deploy the Windows Installer setup package for a specific component across a network. To deploy components that require file extraction, you must have administrator privileges on the target computers.

  • Would this work for Windows 8/2012 ?
    – Jeff
    Commented Apr 25, 2014 at 12:41
  • The "deploy it using the Active Directory" link is broken. Is there a current version? Commented Sep 20, 2016 at 8:57

ok - I have an answer for this problem - not the one I hoped for... but it does work. If you grab the .cab file from the Windows install disc under sources\sxs then run the command:

dism.exe /online /enable-feature /featurename:NetFX3 /source:"sources\sxs"

Windows will install dotNet offline without affecting the WSUS configuration. This would be easy enough to script into the logon script. I've tried it out on Windows 10, so I guess it would work on previous OS versions too.


First of all you do not need all .NET framework packages, 3.5 SP1 will do. Try approving some other update and check if it installed. If not, something else is not working as expected. You can also check the file WindowsUpdate.log for errors, sometimes it really helps.


The proper way to do this is mentioned in a technet disccusion, but I'll post it explicitly, here, since those links tend to die over time...

What you want to do is enable the "Windows 10 Features On Demand" product in WSUS.

An alternative that also worked for me on a WSUS server that, for some reason, the client didn't want to do that, was to change a group policy setting that allows Windows clients to download new features from Microsoft, directly, for new features.

In GP Editor, open whatever GPO you use to control your Windows Update settings, and go to Computer Configuration > Policies > Administrative Template > System.

In that folder, there is a setting called Specify settings for optional component installation and component repair. Enable that setting and check the box that says Download repair content and optional features directly from Windows Update instead of Windows Server Update Services (WSUS)

Then, wait for the GPO to replicate to all domain controllers, and either reboot the Windows clients or do a gpupdate /force to grab the new policy, and then try your feature install.

This works for all optional Windows features, including .NET 3.5, WSL, and anything else you might want to add.

For reference, I found the GPO solution on a blog post here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .