For some reason data & graphs for IO Service time and IOstat do not show up in munin. All other graphs are fine. Can some one suggest me how to set munin to show the stats and graphs for these. Am I missing any packages?

  • Problem solved? If so, how did you solve it? – 3molo May 4 '11 at 7:36
  • The issue is with the plugin. I did not see any values for those two plugins when I ran those at the terminal. Is there any other option to get those working other than reinstalling munin? – RajeshT May 4 '11 at 19:49

I ran into the same problem (on an EC2 instance running Ubuntu Lucid Lynx) and figured out the solution via a comment at the top of the plugin code.

Basically the plugin by default skips all hard drives which have a number in them. To avoid this you need to add the following lines to the plugin config file (/etc/munin/plugin-conf.d/munin-node for me - I needed to edit it as root):


Then restart munin:

sudo restart munin-node

Of course you also need to have made sure you have iostat available on your system (running iostat at the commandline should tell you). If not then it's pretty easy to install (on Ubuntu):

sudo apt-get install sysstat

I ran into this problem as well. It is actually an issue with iostat not returning information about the state of the devices in the system. If you run iostat from the command line, you should see something like this:

# iostat config
Linux 2.6.18-194.11.4.el5 (hostname.tld)    08/10/2011

avg-cpu:  %user   %nice %system %iowait  %steal   %idle
           0.06    0.04    0.05    0.05    0.00   99.81

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn

I was able to get the devices to show up by restarting my system.

Device:            tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
sda1             73.53      2532.05       142.72     255762      14416
sda2              0.29         8.08         0.00        816          0

You may need to install the sysstat package first.

On Ubuntu run sudo apt-get install sysstat

Then run iostat to check that stats are available.


do you get values by running the plugins in the terminal?

it's often: /etc/munin/plugins/plugin_here

If you do, continue and connect locally to port 4949 and try to fetch the plugins data

nc 4949

fetch plugin_here

If the first step does not work, it's usually because of syntax errors, or it was written for another platform or so.
If the second step fails, it's often because of that munin runs as specific user (munin), and some plugins need uid 0 privileges so edit /etc/munin/plugins.d/munin.conf (or is it munin-node.conf?), and enter for example:


If all that works, go to the munin-graph.log (and munin-fetch.log) of the munin server to see what actually happens. tcpdumping can also tell you alot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.