I need to mount an external USB drive formatted as UFS on a Mac running Snow Leopard (OS X 10.6.7). OS X has no support for UFS, but I understand you can run a virtual instance of an OS w/UFS support and use that to get files to the Mac host. Trying both FreeBSD and Ubuntu 11.04, WMWare is showing that the drive is indeed connected to the VM, but it does not get auto-mounted. That's fine, but I cannot find the device in /dev in order to mount manually. Also, booting the VM with and without the external drive connected shows no difference in the contents of /dev - i.e. I would expect to find an additional device relative to the contents of /dev when the drive is not connected. I have tried the same on Virtual Box, with the same result - no new device in /dev. Thoughts?

  • 2
    What does the output of dmesg shows? It should indicate what dev got connected to the host. – Vick Vega May 3 '11 at 14:44

In Linux "fdisk -l" will show you all available partitions on the system. Also check dmesg.


You may need to install this:

Virtual Box Extension Pack

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.