I am having some difficulty using the Windows 7 FTP server. I would like to be able to connect anonymously and upload files to the FTP root directory, but I get access denied error messages when I try.

I have turned on the windows features InternetInformationServices->FTP Server->FTP Service and Internet Information Services->Web Management Tools->IIS Management Console

In the Internet Information Services (IIS) Manager under Default FTP Site I have Allow All Users Read,Write permissions.

I have enabled Anonymous Authentication and Basic Authentication.

I have temporarily disabled the Windows 7 firewall.

I am able to use FTP from a remote PC to view a directory listing of the FTP root directory. But, I cannot upload data to it. When I try, I get this error:

ftp> put somefile.txt
200 PORT command successful.
550 Access is denied. 

The PC hosting the FTP server is on a domain. I do not have domain admin rights.

What settings do I need to change to allow anonymous uploads to the FTP server?

Thanks, PaulH

  • How about the file system permissions. Does the user running the FTP service have write access to the destination folder? (This is separate from the IIS permissions) – SmallClanger May 3 '11 at 17:09
  • Yes. The user has local admin privilege and can write to that folder. – PaulH May 3 '11 at 18:03
  • use the port 22 while connecting to the FTP server – Gaurav Singh May 20 '11 at 8:58
  • I had the same problem - and this solution worked for me. Thanks! – user152854 Jan 10 '13 at 16:11

I had a similar issue on Windows 7, but I solved it by allowing the "Users" group write and modify permissions on the file system folder which was the FTP root.

  1. Find the ftp root in your file system
  2. Right-click > Properties > Security
  3. Edit the settings for the "Users" group to include write and modify permissions

I think this is required because the anonymous FTP user will assume the privileges of the IUSR_... Windows account - which isn't necessarily the same user as the one running the FTP service?

Hope this helps.

  • I ended up switching to FileZilla, but this answer looks good. :) – PaulH Nov 11 '11 at 19:18
  • +1: This answer fixed the same problem for me! – Rising Star Jan 30 '14 at 20:38

IUSR is the actual local user account (with modify permissions) IIS uses to put files. So, all you need to do is add IUSR to the ftproot folder (and all items within).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.