0

I've set up a Squid proxy which requires Windows Authentication. When Internet Explorer users try to use HTTPS websites, it just fails. FireFox users don't have this problem. I cannot imagine of any reason for this.

  • So.... No answers? – Parsa May 20 '11 at 18:54
0

Please provide more information.

  • When browsing HTTPS sites on Internet Explorer, do you see related activity in the Squid logs?
  • When browsing HTTPS sites on Firefox, do you see related activity in the Squid logs?
  • Using an authenticated proxy requires manually specifying the proxy server in the browser. Have you done this for Internet Explorer?
  • When browsing HTTPS sites, the client endpoint must be aware of the proxy interception, so again the proxy needs to be set in the browser.
  • Internet Explorer simply fails when faces the 407 response. That's what shows up in the logs. Yes, all activity is logged in the Squid when using FireFox. Yeah sure, the browser's configured. Some applications have username/password fields for proxy authentication, but mostly they use the proxy settings used by Internet Explorer so when it comes to authentication just a dialog box pops up and asks for username/password. – Parsa May 6 '11 at 12:47
0

Internet Explorer does not support any kind of Authentication with HTTPS proxies. (Tested IE 6 through 10)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.