I have a Windows Server 2008 R2 network share setup as a map drive in Win 7 x64. I want to search it via Windows 7 but I always get "no items match your search". It's as though it's not even attempting to search.

The File Server role with Windows Search Service is installed. The drive holding the network share is added to the indexing options on the server, and it indicates that indexing is complete.

From what I understand, the search query should be sent to the server (where the content is indexed), executed, and the results returned.

Failed solutions:

Source: http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/afb904c1-1c61-4aae-b6b1-5cf525b9f8de/

  • create a symbolic link to the UNC. I find that to be an extreme fix to what should be a simple problem.

  • enable "Always Available Offline" for the UNC. In a corporate setting it's not acceptable to duplicate all server content locally, nor is it feasible with many TB's of server storage.

  • install the "Windows Desktop Search: Add-in for Files on Microsoft Networks" http://www.microsoft.com/downloads/details.aspx?DisplayLang=en&FamilyID=f7e981d9-5a3b-4872-a07e-220761e27283 It allows a UNC path to be entered into the indexing options on the client and then the index built locally. However, the add-on is not for Windows 7 and is not supported for x64.


  • The setup includes two clients (Both fully updated Win7 x64), one file server, no domain. Just to make it easy (security isn't an issue in this case), anonymous access is used. I really doubt it's a permissions problem as I can access, modify, and create content on the mapped drive. I just can't search it.

  • Searching on the server ALWAYS works. The share in question has lot of content: 2.17TB with 274,633 Files, however, the folder(s) I wish to search has only 11,503 files (54.3GB)

  • Searching on one of the two clients works most of the time. It appears to be somewhat unreliable. Some days it works, others it does not. Searching on the second client has never worked.

  • The index has been rebuilt on the server as well as both clients.

Update 2:

  • From the client, if I highlight all files in the share, go to properties, and let Win 7 count the files, then proceed to do a search after the counting is complete, it works. I'm not sure why that worked (something to do with rebuilding the index, properly this time?). I have a feeling that as the fileserver content changes it wont stay working. Any thoughts?
  • 2
    Any chance the UNC path you're using is a DFS path? If so, that is unfortunately not supported, which I had to find out the hard way.
    – Jordan W.
    Commented May 23, 2011 at 13:20
  • No, the DFS service is not installed.
    – mbursill
    Commented May 23, 2011 at 15:28

10 Answers 10


Given that you're trying to search a server and not your local system, it's probably not related to indexing as you shouldn't have all your clients indexing a file server.

What happens on the system that doesn't work if you login as a completely different user and try to search the sever? If you get results, try the steps laid out on this site

There's a registry key:


In this key there are two values (both hex dword)

Start_SearchFiles Start_SearchPrograms

Uninstalling Windows Search sets the value of both of these to zero, when they default to something else. However, reinstalling Windows Search does not restore them to their default setting like it probably should. By manually setting both of them to 1, it re-enabled the windows search function from the start menu. Somebody might want to notify one of the Microsoft software engineers that they should correct this issue so that reinstalling Windows Search properly configures this registry key back to its default setting, that way if anybody else does what I just did they'll avoid the same headache I went through. (I don't know how to contact them myself.)

Another thing to try would be to try the steps outlined on this site

  • As indicated in the second link, the Organize/Search setting for: "Don't use the index when searching in file folders for system files" may have done the trick. After turning that on, mapped folder searching is working. I've been tricked into thinking its fixed before (sometimes after a few hours it reverts back to the broken state). I'm optimistically cautious about this fix and will mark this as the answer if it proves positive.
    – mbursill
    Commented Dec 18, 2011 at 17:54
  • Not sure why it has worked, but turning on the option "Don't use the index when searching in file folders for system files" did the trick. Obviously the mapped drive does not contain any system files. Very strange.
    – mbursill
    Commented Dec 20, 2011 at 15:20

Go to Home Group on the Windows 7 machine in control panel (I know, but bear with me...). Click on "change advanced sharing options" and in the public section, turn ON network discovery (or toggle it off, apply, on, apply, if already on). Re-index and reboot.

This is just a suggestion. Also, do you notice if the shared network drive appears with an X on it, even for a brief time period, when the machine is turned on? Win 7 has a habit of giving up indexing a network share if it is not available immediately on bootup, even if it subsequently becomes available, like in 30 seconds.

I suspect that this is something to do with the Home Group interaction, even if you have it turned off. I have spent literally days getting machines to be visible when, for no apparent reason, they are immediately available to other machines on the same OS. All these cases involve some type of Windows 7 "homegroup" issue.


Try going in from the client PC and right click on the mapped drive. Make sure that "allow files on this drive to have contents indexed..." is checked.

The other option that I would check would be: double click the mapped drive, select all folders and then right click on them, click advanced, then make sure that "folder is ready for archiving" is checked and "allow files in this folder to have contents indexed" is checked.

I think that these settings are usually set on a per pc basis, not taken from the server's settings.


I got this working at a site I look after, where they have a need to search in specific folders on the network for scanned documents, and to search text within PDF files. Works beautifully. From a collection of about 70,000 files, they can search almost instantly over the network for filenames and PDF documents containing specific text. Sorry, this doesn't address your exact problems, but hopefully you, or someone, benefits from my efforts. I emailed someone my results so as to tell them about it and to document it. Now shared here :)



Two hours of ****** around and a further two hours of searching and I finally find this:


This is exactly what I'm looking for!! Why couldn't I find a single MS website telling me this **?!?

... users of Windows 7 can also search content stored in shared folders on the network. To do this, the following prerequisites are required: The remote computer must be running Windows 7, Windows Vista, Windows Server 2008, Windows Server 2008 R2, or Windows XP or have Windows Server 2003 with WDS 4.0 installed. The Windows Search (WSearch) service must be running on the remote computer (on Windows Server 2008, you can enable the search service by installing the File Services role and then enabling the Windows Search role service within that role). The shared directory on the remote computer must be included in the indexed scope on the remote computer. Note To provide an optimal experience for remote search, Microsoft recommends that computers running older installed versions of Windows with WDS 2.6.6 or WDS 3.01 be upgraded to WDS 4.0. For more information concerning support for WDS, see the section titled "Understanding the Windows Search Versions" earlier in this tutorial.

Remote search performed from the local computer uses the Windows Search service on the remote computer to perform the query against the index on the remote computer.

  • Just to clarify, the only index in this solution is on the server. NONE of the clients keep their own index. All the clients run windows 7 and didn't need anything special done to them to make them work (barring anything on that website I might have forgotten). I believe Windows XP clients would have needed windows search 4 installed, but wouldn't have needed a local index. I had to ignore/disable the indexing service built into the server (windows 2003 server) and install Windows Search 4 on the server. Then I configured Windows Search using group policy.
    – Julian
    Commented Apr 2, 2013 at 7:42

Sounds like a case of bad/incomplete/corrupt indexing.

Have you tried the exact same search directly on the server? If that doesn't work either, may I suggest forcing a rebuild of the index:

  1. Click Start, click Run, type regedit, and then click OK.
  2. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search\SetupCompletedSuccessfully
  3. On the Edit menu, click Modify.
  4. Type 0, and then press ENTER.
  5. Exit Registry Editor, and then restart the computer.

(Steps taken from MS knowledge base.)

  • This looked promising but didn't do the job. I did learn, however, that it's only one system which is affected. The server its-self can execute searches without problem. I tested another Windows 7 client and searching of the mapped drive works successfully. Unfortunately, the system that gets used more often (and requires searching) still fails. Would the index of a mapped network drive really be copied local? Shouldn't the query string be sent to the server for execution and only the results returned?
    – mbursill
    Commented May 19, 2011 at 14:50
  • As far as I know, a mapped drive is a simple shortcut to a UNC path. There's no connection made to the remote services (e.g. Windows Search service of your Win2k8 server) through mapped drives. Now that I think of it, maybe you need to verify that the mapped drive is actually being indexed on the Win7 machine. Go in Indexing Options from your Control Panel and check the mapped drive if it's not checked. If it is already checked, click Advanced and then Rebuild to rebuild the index. Hopefully that will do it.
    – Olivier L.
    Commented May 20, 2011 at 4:32
  • Just read here that, as you said, Windows is intelligent enough to use the remote index on UNC paths. Learn something everyday. Anyway, if you haven't done so already, maybe you'll want to troubleshoot your issue through the Indexing Options of the Win7 machine. Maybe remove local indexing of the mapped drive if it's currently set?
    – Olivier L.
    Commented May 20, 2011 at 4:39
  • @mbursill, are you sure permissions are okay for that one computer that can't get anything? (both user and computer accounts?) Server 2008 should do the search, then filter out what you don't have access to.
    – Brian
    Commented May 20, 2011 at 13:31
  • @Olivier, with Win 7 you cannot add UNC or mapped drive to the local index. You load up Indexing Options, click Modify, then "Show all locations". You see everything local, even removable disks, but nothing remote. That said, I tried a rebuild anyway, and when it finally finished, I still couldn't search the mapped drive. The exact same search string (one word) on the server or second client works, but not on this one Win 7. Searching locally indexed content works fine.
    – mbursill
    Commented May 22, 2011 at 17:22

If Microsoft's options don't work out, you could try these (untested) alternatives:


You need to include the mapped drive to indexing options in win 7.


Try creating a new Library and including the folder in the Library.


What all descriptions seem to miss, is that even on the client system, given it is running Windows Server 2008 and above (say as Remote Desktop Server), Windows Search will only work, if the RDS has the File-Services role installed and the Windows Search feature is enabled.


I tried this simple modification and worked like a charm. Got this from some genius named Thekid2point0 on another site:

"Not sure if this would help but I had a user with this same issue and after awhile changing all the settings I could find, I found one that did the trick. Under the Folder options go to the Search tab and under how to search check the "Don't use the index when searching in file folders for system files" check box close windows explorer and then reopen and try your search again. This worked for me hopefully this will help someone else out there."

  • Ideally you should always link to your sources. I would also suggest getting more to the point as half of this is useless. Commented Jun 29, 2016 at 4:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .