0

I am currently ingesting millions of rows of data into a MySQL database. I am monitoring the server status locally on my machine using MySQL Workbench. The application is showing that the memory is maxing out. Please see the image below.

enter image description here Is there a way that I can fix this in MySQL Workbench. Perhaps a setting of some sort. I am a new to MySQL and servers.

Thank you for your assistance.

  • Is this on a linux server? If so, post the output of free -m. – EEAA May 5 '11 at 4:57
  • No I am running the server on my Mac Book for now. – David May 5 '11 at 4:59
  • That metric is only going to mean anything to people who know the inner details of what MySQL Workbench is measuring. Without that knowledge it doesn't matter if it's 100%, 5%, red or banana. And even if it is usiong all the memory available - so what? Do you have performance problems? – symcbean May 5 '11 at 12:37
1

Also check which my.cnf you're using. The development & deployment versions are very different in case of caching and memory usage.

0

Don't worry about the 99% used number. All unix based OS's will report that due to using all memory for disk caching. The OS will free the memory as needed. For your true free memory in your finder run

Activity Monitor

Then there is an option towards the bottom for memory. You can see your true free memory minus the file system caching if you look at the Inactive option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.