IIS 7.5 FTP IIS Manager Users Login Fail (530)

I'm trying to set up a FTP site on IIS 7.5 that allows IIS Manager Users to login. I'm following this guide: http://learn.iis.net/page.aspx/321/configure-ftp-with-iis-7-manager-authentication/.

After set up, I cannot login to the FTP using an IIS Manager User account. The client error I got was 530 User cannot log in. Win32 error: Unspecified error. Error details: An error occured during the authentication process.

I tried both with or without a virtual host. A Windows account login fine.

The only strange thing I noticed was that when setting up Read permission for Network Service, there was an access denied error when setting up permission for "%SystemDrive%\Windows\System32\inetsrv\config\schema".

Any thoughts? Thanks!

3 Answers 3


Turned out I didn't install FTP Extensibility. There were two sub-items under FTP Service in IIS Role Features. I only selected the first one and didn't enable FTP Extensibility, which IIS Manager User and ASP.NET Membership rely on.


I tried installing the FTP Extensibility role service as suggested by Jim but to no avail. In fact, I suspect that the "FTP Publishing Service" shown in the list of available roles is the old IIS6 service rather than the newer IIS7/FTP7 version. The description of the "FTP Management Console" subitem has a description containing the line, "IIS7 users IIS6 management console for FTP server management", which rang a bell - I think I remember installing this by accident before and only realising when the IIS6 suddenly appeared in my Programs list.

What did do the trick for me was simply setting permissions on a few files and directories. I got the basic information from http://www.trainsignal.com/blog/windows-server-2008-ftp-user-authentication, but the commands were outdated (they used CACLS which is now deprecated in favour of ICACLS) and the syntax is a little different, so I had to adapt them slightly. You can do the same job in Explorer but I did it this way (at an Adminstrator command prompt):

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config" /grant "Network Service":(R)

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\administration.config" /grant "Network Service":(R)

ICACLS "%SystemDrive%\Windows\System32\inetsrv\config\redirection.config" /grant "Network Service":(R)

and then:

ICACLS "%SystemDrive%\inetpub\ftproot" /grant "Network Service":(M)

I then restarted IIS and the FTP service on my website and was able to log in using IIS Manager Permissions as expected.

  • Jim's answer are right, it's solved the first error but generated another error that resolved with your answer.
    – rkawano
    Sep 3, 2014 at 17:01

I suspect that the Network Service account is lacking permissions on the directory you mentioned, since you got the error setting the permissions for the Network Service.

Check the folder's permission in Windows Explorer's security tab. Set the read permission if it's not set and restart the service.

  • I don't know if everyone encounters that error, but I tried on two newly installed server and both got the same error. FTP works fine (after enabling FTP Extensibility) though.
    – Jim
    May 7, 2011 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .