3

I'm trying to figure out how to disable or uninstall gzip from my Ubuntu server. This is to support a package of buggy software that breaks when it's trying to do a crazy call to a css file (don't ask, the code architecture is horrifying). The support team suggested that I uninstall gzip from my server to fix the problem.

I see this in my phpinfo();

HTTP_ACCEPT_ENCODING gzip,deflate,sdch

But I can't figure out where in Apache to set or disable this thing. I did find the below stuff in a file called magic when trying to find where deflate was being used (my research indicated deflate and gzip are linked somehow):

0       string          \037\235        application/octet-stream        x-compress

    # gzip (GNU zip, not to be confused with [Info-ZIP/PKWARE] zip archiver)
    0       string          \037\213        application/octet-stream        x-gzip

    # According to gzip.h, this is the correct byte order for packed data.
    0       string          \037\036        application/octet-stream
    #
    # This magic number is byte-order-independent.
    #
    0       short           017437          application/octet-stream

I just want to turn gzip off for this application to see if my page will stop throwing a 416 HTTP error.

2

Disable the mod_deflate and mod_gzip modules.

In Debian-types:

   a2dismod mod_deflate
   a2dismod mod_gzip

In RedHat-types, modify the *.conf files stored in /etc/httpd/conf.d/

1
  • In my Ubuntu 10.04 I had to type deflate, without the prefix mod_ – franzlorenzon Jul 9 '13 at 8:46
2

...and in Ubuntu you'll find the .conf file for mod_deflate in /etc/apache2/mods-available. mod_gzip isn't in the standard Apache loadout on Ubuntu, so the odds are that it's mod_deflate.

1
  • I wish I could mark both of these as right....it is helpful to know where the locations of things are in addition to the fact that the first answer pertains to something you issue via the command line (rather than adding to a conf file). Thanks! – Lynn May 5 '11 at 23:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.