We're experiencing issues with our Windows 2003 server, which runs SQL Server 2005 SP1. We notice that sometimes the entire server becomes unresponsive and I captured a screenshot of the task manager when this happened. I noticed that the processes are not displayed during this time and all of the memory information and handles disappear (as shown in the screenshot). Does anyone have any ideas as to what could be wrong with this sytem? I'm planning to take it down over the weekend to run Memtest86.

Screenshot: http://dl.dropbox.com/u/2058/windows_screenshot.png

The issue is resolved by a reboot, but I'd like to figure out the cause of this and get it fixed.

I also tried to run a ping when this occurred and I got the following error in the event log:

"Application popup: ping.exe - Application Error: The application failed to initialize properly (0xc0000142). Click on OK to terminate the application."

Thanks, Derek

  • What SP are you running for the OS? Also, any reason not to update to SP4 for SQL? – DanBig May 6 '11 at 19:03
  • You need to isolate more. What is occasionally? Do you have scheduled tasks that run at this time? Users submitting large changes to the DB? – Holocryptic May 6 '11 at 19:12
  • 2003 SP2. We haven't upgraded SQL Server to the latest service pack. We're just afraid something will break but I guess it's worth a shot. We do have database dump jobs that run occasionally, but the issue is hard to isolate because we sometimes go weeks without issues. The server runs our accounting system database (MAS500), IIS, and a Tomcat instance. We have some custom web applications that pull data from the database. – Derek Ivey May 6 '11 at 19:22
  • That behavior sounds like a memory leak. Take a full backup of the system, including separate backup for system state and apply all outstanding patches. – Vick Vega May 7 '11 at 1:47
  • I also tried launching Sysinternals Process Explorer and got an error "not enough resources." After some searching, I found this thread: forum.sysinternals.com/…. They mention the /3GB switch in boot.ini might be causing issues. I noticed that we have this enabled; could this be our problem? The server has 16 GB of RAM and we're using Server 2003 R2 x86. – Derek Ivey May 7 '11 at 3:43

Based on your answer and comments, I'm going to guess that you also had PAE running in conjunction with the /3GB switch, which would cause your system to seize up like 80 year old arthritic joints. You need to a) read up on PAE and /3GB and b) for the love of $DEITY, move to x64 architecture. I know the economy is tight, but if you're straining the server like this, it's time to move to post 2003 technology. Some links on /3GB and PAE:

Consequences of running 3GB and PAE together

Enable PAE in x86 32-bit Windows Server 2003 and 2000 to Use Large 4GB or More RAM Memory

Physical Address Extension

Driver may not be loaded with the /3GB switch

Kernel address space consequences of the /3GB switch

Myth: PAE increases the virtual address space beyond 4GB

How to monitor and troubleshoot the use of paged pool memory in Exchange Server 2003 or in Exchange 2000 Server

I would hazard that something is trying to reserve a large block of contiguous virtual memory addresses in the kernel address space, and the system is locking up at that point. The only way to check that is to run Poolmon and monitor the system.... but like I said, it may be worth your while to just buy new hardware and move to a x64 infrastructure.

  • Yes, we're using PAE. I'd love to move to 64-bit, but the accounting software we use apparently doesn't support 64-bit Server. I don't know if the newer versions of MAS 500 support 64-bit or not, but we're on an old version because they made a bunch of modifications to it :/. – Derek Ivey May 7 '11 at 23:55
  • That's unfortunate. Well, the best thing to do is leave the /3GB out while leaving PAE in and monitor with Poolmon. – Holocryptic May 8 '11 at 0:08
  • Yeah, I've been monitoring it since I rebooted it last night and it looks good so far. I'll know for sure when the work week starts. – Derek Ivey May 8 '11 at 0:19

I believe removing the /3GB switch from the boot.ini file resolved the issue. Before removing it and restarting the server, my Free System Page Table Entries count was 844. After removing it and restarting, my count is now at 157252. I'll wait a few days and see how it behaves, but I'm fairly confident that fixed it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.