I just installed a private Ubuntu Enterprise Cloud with Ubuntu Server 11 (based on Eucalyptus 2) and managed to get everything working (in System Mode, so the instances get an IP from our DHCP. Eucalyptus recognizes this IP).

However, I have a really strange problem and could not find any info here or on Google.

The Problem is that I cannot connect via SSH to any instance. I tried different images from the store, 64 and 32 bit. Also from different source computers, including network PCs, the CC and the node itself.

Here is the output from the console:

cloud-controller:~$ ssh -i .euca/mykey.priv -v
OpenSSH_5.8p1 Debian-1ubuntu3, OpenSSL 0.9.8o 01 Jun 2010
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file .euca/mykey.priv type -1
debug1: identity file .euca/mykey.priv-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu3
debug1: match: OpenSSH_5.3p1 Debian-3ubuntu3 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.8p1 Debian-1ubuntu3
debug1: SSH2_MSG_KEXINIT sent
Read from socket failed: Connection reset by peer

So, the server is running but closes the connection immediately. What could be the cause for it? Unfortunately I have no other option than SSH to login into the instance, it's a fresh install.

Thanks for any solutions or hints! Michael


You need to add the username to be used on the instance. Even if you are login in with a private key, the system need to know the username.

If you took your image from Ubuntu's store the username is : ubuntu

So your command should be :

ssh -i .euca/mykey.priv ubuntu@
| improve this answer | |
  • Yeah, sorry, of course I used an username (just not in the example above). As you see the SSH-Connection is closed even before authentication starts... – Michael W. May 13 '11 at 9:11

I have same problem but I solved it by execute this command, from UEC tutorial:

euca-authorize default -P tcp -p 22 -s

Now try to launch a new instance to test it!



| improve this answer | |
  • 1
    We switched to XEN because we could not fix our problem quick enough, but we will give Eucalyptus another try later this year. Thanks for your post, I'll try your command then. – Michael W. Aug 10 '11 at 10:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.