12

Somewhere some software install must have died. Now when I try to install software, I get popup message from the Windows Installer saying "Another program is being installed. Please wait until that installation is complete, and then try installing this software again.".

A search on serverfault brings up "Windows Installer Cleanup Tool" which Microsoft has stopped supporting. Another search lead me to WiseFixer which wants $50 to fix my computer.

I don't mind paying some money to fix my computer but I no longer trust things I find via most product review sites or web searches.

  • 5
    Have you tried rebooting? After all, it is a Windows machine. – jamesbtate May 10 '11 at 20:02
  • 1
    Have you tried reregistering msiexec? support.microsoft.com/kb/315346 – xXhRQ8sD2L7Z May 10 '11 at 21:17
  • To let Google catch up on this, the German error message reads "Ein anderes Programm wird momentan installiert. Warten Sie, bis die andere Installation abgeschlossen ist, und wiederholen Sie anschließend die Installation dieser Software.". – Uwe Keim Mar 7 '16 at 12:38
  • 1
    In my case it was a process called "TiWorker.exe". No matter how often I killed "msiexec.exe" via Process Explorer, it keeps popping up, again. After I killed "TiWorker.exe" and then killing "msiexec.exe", it did not pop up again. – Uwe Keim Mar 7 '16 at 13:23
  • solved it by searching and killing all task name that appear with "installer" in their name – JinSnow Nov 4 '16 at 15:55
12

Open regedit and see if this key exists:

HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\InProgress

If so, remove it. Restart the Windows Installer service after removing the key.

  • I've seen regedit before but I don't remember where is is located. Should I edit it as a text file or should I run regedit? – Cathy Sullivan May 10 '11 at 20:37
  • 2
    Start, Run, type 'regedit' and navigate the tree from there. – Holocryptic May 10 '11 at 20:42
  • 4
    Someone who has to be told exactly how to run regedit probably really shouldn't run regedit. – Ward May 11 '11 at 3:31
  • Seems to have worked. I also used System Mechanic to clean things up. And I rebooted after I removed the key listed above. – Cathy Sullivan May 11 '11 at 8:53
  • How to stop it when net stop msiserver is unable to stop it? – Abdul Rauf Jul 28 '16 at 7:21
10

Fire up Process Explorer and hover your mouse over each instance of msiexec.exe. With a bit of luck you'll get the command line of what's installing which should give you some clues as to what it is.

Process Explorer msiexec example

I get this from time to time and it's my antivirus installing something which I can only guess is new definitions, because it happens frequently enough for me to notice.

2

Sorry if this is a basic response...but, do you have any pending windows updates that need to have their installation finalized via a reboot?

On a side-note, using Windows Installer Cleanup Tool was the biggest mistake I ever made. Just thought I'd throw that in. ;)

  • 1
    I've have rebooting this machine many times so there is no finalize with a reboot pending. – Cathy Sullivan May 10 '11 at 20:12
2

First thing is to try stopping the Windows Installer Service. That may resolve the problem in itself. Quite possibly Windows is installing updates in the background.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.