2

We have an app which sits behind an Apache instance using mod_proxy to pass requests to the correct app server.

Our app correctly returns a Connection: Keep-Alive when queried directly, but mod_proxy is scrubbing the header.

I did some reading and a few suggested that the client needs to set a Proxy-Connection: Keep-Alive to the the proxy about this, but that didn't work either.

Is it possible to have persistent connection proxied by apache?

  • Is the KeepAlive parameter in apache on or off? – becomingwisest May 11 '11 at 7:14
  • It is off at the moment, however my reading suggests that the KeepAlive parameter refers to sending TCP keepalives to the backend, and seems somewhat seperate to the HTTP 1.1 Keep-Alive. – richo May 11 '11 at 22:58
1

Given that you say apache has KeepAlive off, I'm guessing its closing the connection. Try turning it on per KeepAlive

  • I tried it after I read your comment. Didn't fix the issue. Some weird gzip flag did in the end, and then to add insult to injury the top level problem turned out not to be anything to do with apache. – richo May 12 '11 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.