I got a clean installation of Windows Server 2008 Enterprise R2 from my hosting provider. When I try to add a Actice Directory Domain Services role to the server I get a message that the installation is not successfull and the server needs to restart in order to revert all changes. Here's what I have in the server log:

[CbsUIHandler]              Error: -2147021879 : 
[CbsUIHandler]              Terminate: 
[InstallationProgressPage]  Verifying installation...
[CBS]                       ...done installing 'DirectoryServices-DomainController '. Status: -2147021879 (80070bc9)
[Provider]                  Skipped configuration of 'Active Directory Domain Controller' because install operation failed.

I have installed all updates and SP1 - it didn't help. Does anyone have a suggestion how to fix this problem?

EDIT: By recommendation I have run a check with System Update Readiness tool - it shows no problems.

| improve this question | | | | |
  • Is the DNS role installed? – duenni May 11 '11 at 13:05
  • It was not, but after I have installed it now and tried to install AD DS - it failed again. – FourTonMantis May 11 '11 at 13:43
  • Did you just install it or have you configured it also? – duenni May 12 '11 at 6:22
  • Can you run Windows Update? I frequently see this error code associated with failed Windows Updates. – vcsjones Aug 25 '11 at 23:37
  • I just want to add that this also pertains to Server 2012 R2. Our VM template disables the remote registry service and of course Microsoft thought an error telling you to restart the server when trying to install Active Directory service would make you think the Remote Registry Service needed to be started. I spent the last hour trying to figure this out until I came across this old post. Hopefully someone else will find it as well. – user307391 Aug 28 '15 at 15:26

my problem was Remote Registry service with startup type = disable. Modified in startup type = automatic, problem was resolved.

| improve this answer | | | | |
  • Did you mean to post to this Question? The Remote Registry service doesn't affect the installation of the ADDS Role. – Chris S Aug 9 '11 at 2:52
  • Also, make sure the temp folder is writeable. That's where mine broke. – IguanaMinstrel May 19 '13 at 2:47

Sometimes you will see this error if you have installed "Active Directory Lightweight Directory Services" before installing the ADDS role. Remove the ADLDS role then install the ADDS role first and reinstall ADLDS.

| improve this answer | | | | |

This is a typical problem with a system package, where an update did not install correctly.

Check your Event Log for a package error when trying to install the role.

There is a tool from Microsoft (updated every month) called System Update Readiness Tool (SURT). This tool fixes inconsistencies in the Windows servicing store which may prevent the successful installation of future updates, service packs, and software.

You can find the lasted version of the tool here at Microsoft Donwload Center. The tool for Windows Server 2008 R2 for this month (August 2011) is available here.

Reboot the server after the error. Run the tool. Reboot it again. If this doesn't work you can try manually advanced methods for fixing service corruption.

| improve this answer | | | | |
  • For me it was the default DCOMCNFG limits for local and remote access, needed to add the NETWORK SERVICE account to both. – Tony Wall Feb 17 '16 at 15:58

Actually the Remote Registry Service has to do with this problem, please see the below blog for a thorough explanation and ways to resolve:

Active Directory Domain Services and Remote Registry Service

| improve this answer | | | | |

I upgraded my server from 2008 to 2008 R2 and tried to install AD DS. In "C:\Windows\Logs\CBS\CBS.log" I noticed this error message:

2020-02-13 15:18:40, Error                 CSI    00000005 (F) Logged @2020/2/13:14:18:40.165 : [ml:314{157},l:312{156}]"EventAITrace:Channel Microsoft-Windows-DFSN-ServerFilter/Analytic is declared by an existing provider DFSN-Filter{{564af62f-e581-4998-9991-c4bc18178815}}."

This blog post lead me to the solution in my case: "...an orphaned registry key still needed to be deleted...after that, DFS installed successfully."

There is a key for the GUID (mentioned in the error message) in "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WINEVT\Publishers\{564af62f-e581-4998-9991-c4bc18178815}". After deleting it, installation was successful.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.