0

I'm trying to install perl-suid needed for some script I've downloaded and getting the following

$ sudo apt-get install perl-suid
The following packages have unmet dependencies:
  perl-suid: Depends: perl (= 5.10.0-19lenny3) but 5.10.1-17 is to be installed
E: Broken packages

$ cat /etc/apt/sources.list
deb http://http.us.debian.org/debian/ lenny main contrib non-free
deb-src http://http.us.debian.org/debian/ lenny main contrib non-free

Is there a way to fix the package, install it from source or whatever?

1
  • if apt-get update to get the current package list isn't enough to fix your problem, then you'll need to show us your /etc/apt/sources.list so we can tell you which source is wrong.
    – DerfK
    May 11, 2011 at 13:48

2 Answers 2

1

5.10.1-17 came from Debian squeeze, not lenny, so it sounds like you've got a partially upgraded system there. Did you have squeeze in your sources.list in the past, and then remove it?

You'll need to either downgrade perl to the version in lenny with something like:

apt-get install perl=5.10.0-19lenny3

or re-add the squeeze lines to /etc/apt/sources.list. When upgrading your system to squeeze, you might find the release notes of use.

0

Your system is not up-to-date. The current perl in lenny is 5.10.0-19lenny, but you've only got 5.10.1-17 installed. Run "apt-get dist-upgrade", then try again.

1
  • I really don't want to upgrade all the packages. apt-get upgrade does nothing.
    – synapse
    May 17, 2011 at 9:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.