5

When previous boot was failed. (because of power failure, hardware failure) booting will hang at the grub menu for human prompt.

Can you set option to force boot up no matter what happened?

| improve this question | | | | |
7

Ok I found solution myself via shlug mail list.

what you do is to modify the /etc/grub.d/00_header and find:

if [ "${recordfail}" = 1 ]; then
  set timeout=-1
else
  set timeout=3
fi

change timeout = -1 to 0.

-1 means manual selection.

also remember to update-grub afterward, to generate the actual grub.cfg

| improve this answer | | | | |
  • 2
    If you're on Ubuntu >= 12.04, see KAMI's answer. – kynan Mar 5 '15 at 20:44
4

Add

GRUB_RECORDFAIL_TIMEOUT=0

to /etc/default/grub and that is solved my problem on Ubuntu Server 12.04.4

Grub uses GRUB_RECORDFAIL_TIMEOUT as the timeout when last boot failed. Its value defaults to -1, which means wait forever.

| improve this answer | | | | |
  • 1
    This answer would be better if it contained some information about what the possible values of GRUB_RECORDFAIL_TIMEOUT mean, and what the default is, if it is not specified. – kasperd May 27 '14 at 14:19
  • 1
    This is the correct answer to this question for latest Ubuntu. – Barry Kelly Sep 24 '14 at 23:58
3

This was reported as bug #841009 for ubuntu. I tried setting -1 to 0, but didn't work for me. So i tried another solution given here: https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/841009

Quote:

[...] solution is to set GRUB_HIDDEN_TIMEOUT=-1 as suggested on ubuntu forums at this page http://ubuntuforums.org/showthread.php?t=1403517 but i've not tried this solution yet.

Quote:

grub2 in ubuntu 9.10 server is configured by default with GRUB_HIDDEN_TIMEOUT=0. If there is no keyboard attached (as in my headless setup), this causes grub2 to go to menu and stay there. Setting it to -1 gives me the desired sequence of menu, timeout and default choice.

I don't know if this is a grub2 bug or not, but if this is intended grub2 behavior, the default config for a server distro such as ubuntu server (which you would expect to function headless out of the box) should be different.

It worked for me.

| improve this answer | | | | |
  • Sure sir. The thing is, that link belongs to launchpad that is why i dint tried to illustrating the problem more and pasted the link. But i will surely keep that in mind from the next time. Thanks. – streak Jul 17 '13 at 8:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.