So, at my company, we have three MS Exchange servers. 2 2007 servers (exchange1, and exchange3), and a 2010 server (exchange2), both Standard edition. We are going to take one of the Exchange 2007 servers down (exchange1) to rebuild and install Exchange 2010 on, since we are licensed for that. I'm in the process of moving all of the services from exchange1 to exchange3. I have set up exchange3 with the same roles as exchange1, and moved all of the mailboxes over.

My issue now, is that when I stop the Information Store service on exchange1, people can't get into their email. I'm thinking that Outlook is still going to exchange1 as the client access server, but I'm not entirely sure about that. I have tested, and after moving, the Outlook clients are told to restart, and the new server is in their account settings, but it seems like the organization as a whole is somehow dependent on the Information Store on exchange1 being up and running.

I feel like there is more to be done, but so far I cannot find a technet article or forum post anywhere describing how to do what I want to do.

For reference, here is the output of netstat running on a workstation whose Exchange mailbox has been migrated from exchange1 to exchange3:

Active Connections

  Proto  Local Address           Foreign Address              State
  TCP    workstation:4096        exchange3.example.com:epmap  TIME_WAIT
  TCP    workstation:4097        exchange3.example.com:1044  TIME_WAIT
  TCP    workstation:4103        exchange3.example.com:epmap  ESTABLISHED
  TCP    workstation:4104        exchange3.example.com:53428  ESTABLISHED
  TCP    workstation:4106        exchange3.example.com:1044  TIME_WAIT
  TCP    workstation:4107        exchange1.example.com:epmap  ESTABLISHED
  TCP    workstation:4108        exchange1.example.com:6139  ESTABLISHED
  TCP    workstation:4110        exchange3.example.com:53428  ESTABLISHED

I wonder about public folder stores. Are your clients connecting to a public store on the Exchange1 machine? Each mailbox database has a default public folder store setting. Check out the setting on the mailbox database where you moved the mailboxes.


On that workstation hold CTLR + right click the outlook try icon when connected and choose "Connection Status..." that should tell you what the client is connected to for what service. As Evan pointed out, the clients are likely connecting to a Public Folder Database on Exchange1.


Do you have the client access role installed on Exchange3, and did you make sure that SP2 was installed on Exchange 2007 first?

Run the following command against your 2010 database, to ensure the right CAS is being used:

Get-mailboxdatabase <databasename> | fl -Property RpcClientAccessServer

This is how it should work:

When you move the mailboxes, Outlook clients connecting to Exchange1 will automatically be redirected to Exchange3. In order for this to work "seamlessly", the old server needs to still be up and running. It's generally best to leave the old server up for a week or two just to make sure that all the clients are moved like this aside from the few vacationers, etc.

  • I do have the CAS role installed on Exchange3, and yes, both are exactly the same version. One of the mailbox databases has both exchange1 and exchange3 listed as CAS for the database. I'm pretty sure that database is empty though. Is there an easy way to check? – phuzion May 13 '11 at 17:55
  • What of the RpcClientAccessServer property? – Hyppy May 13 '11 at 17:56
  • Here's the output of the Get-MailboxDatabase command you gave earlier: pastebin – phuzion May 13 '11 at 18:06
  • But when you move a mailbox to Exchange3 then shut down Exchange1, all Outlook clients fail to connect? Netstat and check the mail account settings from a user's workstation to see what the Exchang3 users are really connecting to. – Hyppy May 13 '11 at 18:12
  • Here's the output of netstat with Outlook open on a machine whose user account has been migrated. All irrelevant information has been edited out for the sake of brevity. pastebin – phuzion May 13 '11 at 18:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.