I installed the Oracle express edition (10.2.0) on a Ubuntu virtual machine (I am very new to Oracle Databases). Dpkg returned with a swap error, so i followed this howto to install oracle manually: http://blog.qakq.com/2010/01/oracle-xe-swap-space-workaround-dpkg-x.html

Now, when I run sqlplus and login with either system or sys, I get following error:

ORA-01033: ORACLE initialization or shutdown in progress

I located some error log (/usr/lib/oracle/xe/app/oracle/admin/XE/bdump/alert_XE.log), which has following error message:

ORA-00202: control file: '/usr/lib/oracle/xe/oradata/XE/control.dbf'

ORA-27037: unable to obtain file status

This control.dbf file does not exist. Does anybody know why?

Update: I now tried the fiels from oracle-xe_10.2.0.1-1.1_i386.deb from a ubuntu/debian repository instead of the oracle-xe_10.2.0.1-1.0_i386.deb from the oracle website, the control.dbf isn't missing anymore, but I still get the initialization error..


I think that you need to extend your swap (partition or file) at first. I am trying to install Oracle XE 10.2 on Debian Squeeze via (naturally using oracle repository):

aptitude install oracle-xe oracle-xe-client

This system does not meet the minimum requirements for swap space. Based on the amount of physical memory available on the system, Oracle Client 10g Express Edition requires 502 MB of swap space. This system has 465 MB of swap space. Configure more swap space on the system and retry the installation.

Check Oracle® Database Express Edition Installation Guide for Linux. I suppose that also some kernel params (via sysctl and /etc/sysctl.conf) need to be changed.

  • I added a swap partition to my virtual machine and installed it via aptitude, like this it worked – Schtibe May 17 '11 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.