I am trying to connect remotely to a Windows Server 2008 Machine through WMI Protocol using J-Interop Library. Although I have not been able to configure the firewall properly even after following quite a few online guides. I get the "The RPC Server is not available." error every single time.

I have added following exceptions to my firewall already and believe that these should be enough for the communication to go through, but no success -

  1. COM+ Access
  2. Remote Administration
  3. WMI Access

On the other hand, whenever I turn the firewall off, my code works fine and the communication works perfectly, so I am pretty confident that its only a firewall configuration issue. I can add my code to this post if required and any other information that might be needed for troubleshooting this issue.


RPC generally uses port 135 and a random port above 1024. Here is an article from Microsoft on setting some RPC services to use a specific port(s).

Also, DCOM will not work through NAT, since the actual client and server IP addresses are a part of the handshake.

  • Thanks Hyppy. I am not using NAT and the connection is bridged (Both Server and Client have their own IP Address). Also, my application does not let me choose an RPC port (as far as I know), so configuring the firewall to allow a specific RPC port might not fix the issue. – Elitecoder May 17 '11 at 17:25
  • You may need to allow the entire dynamic range (1024-5000). – Hyppy May 17 '11 at 17:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.