We are having an issue where computers who are not part of the domain cannot resolve the FQDN of a server (but regular hostname and ip do resolve). The strange thing is that this does work when the computer is added to the network.

Our domain name is rather long, its something along the lines of "team.dept.company.com", could that be it?

DHCP server passes along the proper DNS, Name and WINS servers, as well as the domain name. I thought that should've solved the problem, but apparently not really.

Our domain is still windows2003

EDIT: I am starting to believe I can narrow this down to a problem either with the vmware tools NIC drivers that are embedded in my winPE boot image, or to the fact that I'm trying to do this from inside a VM. Pinging a FQDN at the same time when using a different task sequence on a physical machine works.

  • When/How do you try to resolve an FQDN? What does it say when it fails? – Bart De Vos May 18 '11 at 9:01
  • Ping request could not find host <FQDN>. Please check the name and try again. I just happened to check on a third pc, which is on the same LAN but also not in the domain. That one managed to ping the FQDN just fine. The last one I tried it on couldnt. This was in windows, and not in the PXE environment (winPE) like I'm trying with this VM (where it halts because it cannot resolve the FQDN) – HannesFostie May 18 '11 at 9:31
  • Another thing that came to mind is the fact that to boot in winPE in a VM and have a network connection, you need to add drivers to the winPE boot image. Could this be a driver issue rather than DNS issue? – HannesFostie May 18 '11 at 9:37
  • I see you tried to ping the FQDN. Can you ping the DNS servers by IP? If that works, can you query them with nslookup? – Ryan Babchishin Oct 6 '15 at 23:22

From what I gather Hannes, you are using either MDT (Microsoft Deployment Toolkit) or WDS (Windows Deployment Server). In that case, when you load into the PE environment you are not going to be able to interact with the resources you are trying to by design from Microsoft. It's funny you'd ask this, because I just worked with a Microsoft consultant today on this very thing. The PE environment is designed to keep a sort of hedge, if you will, around the systems that are having an OS deployed to them. To interact with them you will need the right drivers for not only the PE environment, but also your system.

Correct me if I'm wrong, but I'm sure you're talking about MDT with PE environment loading from PXE. Let me know and I can troubleshoot further for you.

A link for reference: http://community.spiceworks.com/topic/440812-imaging-with-mdt-and-wds-networking-issues


In the DNS settings in the advanced settings of the TCP/IP protocol on the NIC of the computers in question set the "Append these DNS suffixes (in order)" option with the appropriate DNS suffixes and configure the computers to use your internal DNS server for DNS.


Oops. I didn't read your question and the comments carefully enough. I thought your problem was with resolving unqualified, single-label names. It appears that's not the case. You should configure the computers in question to use the DNS server as their DNS server. When they issue a request/query for the FQDN of a host your internal server should be able to answer it.

As a test you can run a packet capture program on one of the affected computers, start a capture, filter the capture for DNS, issue a query for the FQDN of a host on the network and look at the capture to see what the query is. This should show you if the query is for the proper FQDN or if other DNS suffixes are being appended to the query.

  • I can't do this, we're talking about automatic deployment in winPE here so no way to change that – HannesFostie May 18 '11 at 11:39
  • Thanks for the update. However, my DHCP server sends them the DNS server to use. I can see this by opening a cmd prompt and using ipconfig /all to check configuration. It has the exact same addresses listed (except for the VM's ip address and MAC of course) as my own pc. However, I can ping the FQDN, the VM on the same machine can't. Another pc can ping the FQDN as well, while yet another couldn't a while ago. I'm not sure what is going on... – HannesFostie May 18 '11 at 11:46

Add the FQDN into the DNS Suffix Search List on the computers that are not part of your domain. This is configured under Advanced TCP/IP settings, DNS tab ... Append these DNS suffixes (in order).

  • We are not talking about windows here, this is impossible especially considering we're talking automated OS deployment. – HannesFostie May 25 '11 at 7:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.