For the office we recently bought a WNDR3700 (v1) to accomodate our growing (from one wired and about four wireless to four wired and about eight wireless clients, so not really large) network. We have a Mac Mini server set up as DHCP and DNS server (it has a static IP), so it serves IPs and sets itself as the DNS. I have disabled the DHCP server on the WNDR3700.

What happens is that sometimes the DNS server is not reachable by most (but not all) clients.

I have verified that all clients can ping all other clients, the gateway and hosts on the internet, except that some clients cannot ping to the DNS/DHCP server. Those clients also cannot use nslookup (or dig).

I do not know about any restrictions on the DNS/DHCP server. It's logs don't state anything out of the ordinary and there are no (obvious?) errors.


So the connection was lost again so I tried pinging the DNS server from a PC.


gave replies from (the DNS server), but no other machine.


gives only timeouts.

Pinging from a working machine gives replies from all other working machines on the network.


You need to debug this one step at a time.

First: check that computers connected to the wired network get a valid IP address, and that their DNS server is set properly. Second: check that they can talk to the DNS server (use nslookup) Third: check that there are no restrictions on the DNS server.

There are many possible reasons why this won't work, and your post doesn't have nearly enough information to give conclusive advice.

  • I have tried to give more info, is this useful? – Zsub May 18 '11 at 10:15
  • So basically the second point is the problem: they cannot talk to the DNS server, and I can't figure out why :) – Zsub May 18 '11 at 10:32

How about buy a wifi router that's designed for business use with lots of clients and not a $150 one designed for gamers and movie streaming. Seriously there's a huge gulf between cheapo consumer wifi and pro-grade kit, that's why its more expensive and under the 'professional' tab on manufacturers web sites.

  • Clarified the scale of the network a bit, it's not huge, just slightly bigger. – Zsub May 18 '11 at 9:54
  • Ultimately you've got a consumer grade router, you're less likely to have problem if you'd matched the product with the use-case. – Chopper3 May 18 '11 at 10:19
  • That may be true, and when we're moving (in a month or two) there will probably be an upgrade, but at this time this is what we/I have to work with. And I don't think this is acceptable even for a consumer-grade router. – Zsub May 18 '11 at 10:22

Is there a problem at all with the IP distribution (DHCP) or do you have any IP conflicts occuring? You have just one subnet I guess, any VLANS?. You must be testing the connectivity by pinging, is that right? I can't understand why you think the problem relates to DNS connectivity only. Can these clients ping the server IP all the time?

  • There are no problems with getting an IP, they all get an IP (and DNS info). There are no conflicts. Clients can ping the gateway and even any external IPs, just not the DNS/DHCP server. – Zsub May 18 '11 at 10:10
  • Zsub, do you always have problems with the same wireless clients or does this change? There is just one subnet and one VLAN? – sintas May 18 '11 at 10:25
  • Oh, yes, one subnet (a 192.168.1 with because most people here can remember those) and no vlan (or one, depends on how you see it, I guess, but I haven't configured one). – Zsub May 18 '11 at 10:27
  • Zsub, I am sorry but I am inclined to think that at the time you try pinging your server via a wireless client, you can't be physically connected to the network. If you are saying that by attaching an ethernet cable I suddenly have connection, then probably there is an issue with the wireless signal quality. And also without some kind of restriction, you can't be pinging other hosts except the server. Maybe proximity to the router is an issue. Again I am assuming that that there is no issues with SSIDs, passwords etc. Sorry if this is not an help.. – sintas May 18 '11 at 10:43
  • 1
    We have in the past had similar trouble with laptops that were connected to both the wired and the WiFi network at the same time. The routing got completely messed up and the only solution was to only connect to one network at a time. Have you had a look at the routing tables on the clients? Typically the problem manifests itself by having more than one default route. – wolfgangsz May 18 '11 at 11:09

Well, You're using a broadcast IP address (255) to test responsiveness which could be a problem. I'm not sure how your broadcast host does the ping redistribution but maybe it switches from ICMP to UDP ping, which is not correctly handled by router.

  • It's not necessarily a broadcast address, that would really depend on the subnet mask. – HostBits May 19 '11 at 5:03
  • Well, it is a broadcast address, but that basically was my last resort, as it were, to see if they could reach the dns server which strangely they could (but not any other hosts), while pinging directly they can reach all other hosts, except for the dns server. – Zsub May 19 '11 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.