I think I am having an issue with security on Windows Server. I have a web app that I put on a Windows 2008 Server. I first tried it in Development Server and on my Windows 7 machine and it worked fine. Once I moved this app, a web service that was being called fine before does not work. I assume that I have some outbound set to not allow call from happening. I am not a server guy, I am a bit lost.

Edit: I also trying turning off as much as the security settings as possible.

  • Joe, what are the details behind "does not work". Are you getting an ASP.NET application unavailable message? What is the HTTP response you are getting? Do you get any response at all? Did you check the event logs for clues? In particular I would look at your application event log and the system event log. – Somantra May 19 '11 at 16:58
  • @Somantra I am running the application fine and I submit a call to the web service and nothing happens. No errors, no system coming to a halt. Nothing. I have checked all the logs and nothings seems amiss. I just can not use this web service. there are 4 that call different web services and none of them work. – Joe Tyman May 19 '11 at 20:43
  • OK, you should probably drop down to the HTTP level to see what the server is actually doing. How are you calling the web service? Do you have an HTTP client where you can see the response code and data? That would be what I would try next. – Somantra May 19 '11 at 21:13
  • @Somantra I have a API call in my program that submits an XML/SOAP request. I am looking at the HTTP log and it does not really show that there is a problem there is a lot code 200's. – Joe Tyman May 20 '11 at 14:21
  • So that does sound like the failed request never makes it to the server if you don't see anything but 200's there. Are you accessing locally? Many of the security settings which are involved here are related to HOW you access the resource. So if you you were accessing this via a localhost URL (that works) then move to production and it no longer works, it may be the bindings of the site in IIS. See if you can access locally from the server and also check the bindings of the site in IIS Manager. – Somantra May 21 '11 at 15:52

Turns out that the clock on the host was 12 hours behind the client and for some reason when the clock was change it worked fine. I don't know why this would be the case, but now I know how to prevent it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.