My problem is exactly this same as described here:

Server 2008 R2 - Unable to install any printer drivers Options - google groups

  • I have few Windows 2008 R2 (no SP1) servers in remote offices, mostly in Domain Controller, and many of them have problems installing ANY printer drivers.

  • following errors show up in Event Log when adding printer driver under Print and Document Services/Print Management/Print Services/ /Drivers OR trying any other way to install drivers:

EventID 215: Installing printer driver - failed, error code 0x57, HRESULT 0x80070057. See the event user data for context information.

EventID 215: Installing printer driver Canon iR C2380/2550 PCL6 failed, error code 0x0, HRESULT 0x80070057. See the event user data for context information.

EventID 215: Installing printer driver Canon iR C2380/2550 PCL6 failed, error code 0x490, HRESULT 0x80070057. See the event user data for context information.

  • in this particular server case this is problem with Canon iRC 2380i printer with Canon Generic PCL6 Driver, but it seems to apply to any driver and any printer (tried different drivers, different versions, PCL, postscript, etc)

  • I'm using 64 bit drivers that should be working on this platform.

Any help will be appreciated.

  • Work still in progress, but I think I've found workaround - normally I've been using admin user, member of Domain Admin (created like 10 years ago). Then I've used another account (also member of DA) and all works fine! Checked GPO resolution for both users and is completely different, so I believe some old GPO settings are problem here. Still to investigate in details...
    – toffitomek
    Commented Jun 1, 2011 at 10:40
  • One more thing is happening, when finally managed to install driver with different user, then sharing is failing :/
    – toffitomek
    Commented Jun 10, 2011 at 9:54
  • I think I've finally found solution/workaround, happy to share with You: this seems to be a problem with our user settings and/or GPO, we use 'service' account for most of the modifications on the servers, this account exists within our AD ~10 years, when using this account I'm unable to add printer driver, no idea why. But when using 'new and fresh' admin account all works fine. So I'm adding printers from separate admin account and all works fine.
    – toffitomek
    Commented May 16, 2012 at 9:11

4 Answers 4


90% Fixed:

  1. to install drivers - we had to use another member of Domain Admins, Default Domain Controllers policy reset to default state didn't helped.

  2. sharing printers - (solution found on MS forum, can't find link now)- for some reason Windows Firewall service must be working to share printer, even when all FW settings are set to off/allow. We had Base Filtering service disabled, Win FW was dependent on it and was disabled too.

I found part of the solution on here on Technet


I found a possible fix on what I first thought would be an unrelated site.


The problem they described was replacing a previously unsigned print driver package with a new one. It kept failing with the same 0x80070057 error that we were seeing on some user machines using HP's UPD for x64 Windows 7 PC's. We dumped the output from pnputil to a file, found the OEM package assisted with HP and then deleted it as described in the article. As soon as we did that, the point and print option cleanly installed the driver without a problem. I'm not sure how this manifests itself, as we've got a standard image and we're ghosting it - but as a fix, this seemed to work well.


  • 2
    I been struggling with this for weeks. I use add printer and can not install printers. Well, you fixed my issue. I had to remove the Microsoft ones instead of HP even though it was an HP (cause they are issued by Microsoft ) and you completely fixed my issue. So much I signed up to say thanks.!
    – user282118
    Commented Apr 16, 2015 at 22:18

While its not much help, I have the same printer model installed on the same windows revision without problems. Since you have the same problem on several machines at once then it would seem likely it's caused by active directory or a group policy.

Try taking a look at the security on HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Print. You should have :

system full control
administrators full control
users read access 
TrustedInstaller  Full access

The same goes for HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Ports except that its:

creator owner special permissions
system full control
administrators full control
users read access 

The symptoms are odd enough that I would suspect that this will qualify for a free incident with MS... unless you've been installing any special thinprint type apps.

  • Thanks, last night I've discovered that printer install ok on a server that is not a Domain Controller (funny enough we have ~10 remote offices where DCs works as print servers ;) - so I started thinking what's the difference between DC and standard server? The only answer is GPO. I've been comparing GPOs on DC and normal system, but can't see anything that would lead to my problems. Also I've checked registry permissions as you advised - there are this same on DC and standard box, and this same as yours. I wonder what else can impact driver installation... :/
    – toffitomek
    Commented May 25, 2011 at 7:08
  • You could always try procmon.exe from the MS sysinternals site. It pours out tons of irrelevant stuff and needs to be filtered but it may be worth trying. Try installing an MS generic text only printer queue while doing the monitoring. That should reduce activity down to the core problem. I'd guess a group policy is blocking something or that something has changed the security on a branch of the registry. Difficult to have to track down.
    – Ian Murphy
    Commented May 25, 2011 at 9:37

I had the same issue described in the OP when trying to add any print drivers to a 2008 R2 domain controller, but fixed it in a different way. I found that running the command "net localgroup Users" on my domain controller returned no members. To fix, I ran the following two commands:

net localgroup Users Interactive /add

net localgroup Users "Authenticated Users" /add

I found this solution under Method 2 on a MS knowledge base article to fix another symptom the server was exhibiting: http://support.microsoft.com/kb/970879

Hope this helps someone else as it took me ages to get to the solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .