I am migrating from Exchange 2003 to 2010, I would like to setup co-existance and followed the instructions for setup on technet. OWA redirects without issue, the problem I have is with RPC/HTTPS. Exchange 2003 mailboxes and connect directly to the Exchange 2003 server using RPC/HTTPS and Exchange 2010 mailboxes can connect through the Exchange 2010 CAS with RPC/HTTPS. The problem is if I try to use the 2010 CAS to proxy the RPC/HTTPS connections to Exchange 2003, Outlook never connects.

My UCC cert is valid and contains the external name as well as the legacy.domain.com I have tried switch IIS security to basic as was suggested on the technet forums

If anyone has any ideas I could try please let me know. Or even if they could point me to the right log files to see where the connection is failing on the CAS.

  • Your clients can connect to the Exchange 2003 RPC over HTTPS server w/o problems if configured to do so, though? – Evan Anderson May 25 '11 at 19:23
  • Yes, they connect without issue. – ITGuy24 May 26 '11 at 12:06

Enable Integrated Auth on the 2003 RPC/HTTPS virtual directory.

| improve this answer | |
  • It is enabled on both the RPC and RPCwithCert virtual directories in IIS – ITGuy24 May 26 '11 at 12:05
  • What version of Outlook are you using? – Tatas May 26 '11 at 14:51
  • I have been tried with both 2003 and 2010. – ITGuy24 May 26 '11 at 14:52
  • 1
    Well Outlook 2003 will fail by default to connect due to it not being able to talk encrypted RPC. You need to disable that in Exchange 2010 or get a patch for it I think. Outlook 2010 however should be able to do this. You can do a CNTRL-Right-click on the Outlook icon in the lower right hand corner of the task bar and choose "Connection Status". Do this when the client starts and it should show you to what address and what connection method it's using. Does what it shows look correct? All clients will connect through the 2010 CAS servers and proxy back to the 2003 servers. – Tatas May 26 '11 at 16:56
  • 1
    FYI, I wouldn't recommend disabling encrypted RPC in Exchange, I'd recommend dropping Outlook 2003 as a client, or modifying the client properties to force RPC encryption to be used. – Tatas May 26 '11 at 16:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.