We have a fair number of public folders in our Exchange system. When we create new folders, we assign them an email address and turn off the "Hide from address list" option in order to allow users to copy messages directly to the folder.

The two recent folders that were added are not appearing for Outlook clients. Normally the test is to open a new message, type in the folder name (or enough of it that there is not a "quick entry"), then hit Ctrl+K to resolve the address. It usually works. Now, it does not.

In Exchange manager, viewing the properties of both the All Address Lists/Public Folders and the Global Address List objects (under recipients) and then clicking the Preview button, the two items show up as expected; however, 24 hours later the issue still is not resolved for the Outlook clients.

Both cached and non-cached Outlook clients have been tested. We have also tried the "Update" option on the recipient policies (they have not been changed) and are thinking about the "Rebuild" option, but it always gives the message that it could take a day to perform which is a bit worrisome. I do not know if that means the GAL will not be fully available to users during the rebuild or not.

If anybody has some ideas, I would be most appreciateive.

  • How many users are we talking about in the GAL? Rebuild can be quick enough in a lot of cases (think minutes rather than days), but should be seen as a last resort ("OK, it's time for the Total Annihilation Device") rather than a general purpose solution to GAL problems. – Maximus Minimus Jun 17 '09 at 21:30
  • It's a fairly small number of users, maybe 30, but the number of public folders with addresses runs around 200 if that makes a difference. – palehorse Jun 18 '09 at 14:00

In my experience, the GAL can take longer than 24 hours to replicate entirely. At this point, I tell my users to wait another day before I take further action. 99% of the time it starts working correctly.

  • We may wait another day; however, in the past it has usually shown up within the hour which is why it's so strange. – palehorse Jun 17 '09 at 17:12

Things to check:

  • Make sure replication isn't failing between any of your DCs
  • Make sure the client you're checking the GAL from isn't in cached Exchange mode.

If neither of those is the case, then like Russ W says, just wait a day.


Well, the GAL still wasn't showing the new addresses on the client machines (both cached and non-cached Outlook clients). Another administrator decided to reboot the Exchange server during off-hours. Now the addresses show up.

I'm not sure if restarting a single service would have fixed it, but I suspect that may be the case. If it happens again in the future I'll try to track the service down and post an update.

  • I saw another post where the "File Replication" service was the culprit in that it was not turned on. Something to consider. – Chad Harrison Nov 7 '11 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.