1

When I try to start redmine 1.1.3 I get this error: Missing the i18n 0.4.2 gem. Please 'gem install -v=0.4.2 i18n'

However if I do sudo gem list I get:

*** LOCAL GEMS ***

actionmailer (2.3.5)
actionpack (2.3.5)
activerecord (2.3.5)
activeresource (2.3.5)
activesupport (2.3.5)
daemon_controller (0.2.6)
fastthread (1.0.7)
i18n (0.4.2)
mysql (2.8.1)
passenger (3.0.7)
rack (1.0.1)
rails (2.3.5)
rake (0.8.7)

I'm guessing this has something to do with not finding i18n in the gempath when the application actually runs. Does anyone have any suggestion on how to remedy this?

I can add that I'm using passenger to run redmine. Though I get this error by using ./script/server as well.


I've gotten past this error now (turns out only root could read the gems, chmod a+r solved it) but now instead I get this error:


[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] /var/www/redmine/public/../config/../vendor/rails/railties/lib/rails/gem_dependency.rb:119:Warning: Gem::Dependency#version_requirements is deprecated and will be removed on or after August 2010.  Use #requirement
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] /var/www/redmine/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:62:in `establish_connection': development database is not configured (ActiveRecord::AdapterNotSpecified)
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:55:in `establish_connection'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/../config/../vendor/rails/railties/lib/initializer.rb:438:in `initialize_database'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/../config/../vendor/rails/railties/lib/initializer.rb:141:in `process'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/../config/../vendor/rails/railties/lib/initializer.rb:113:in `send'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/../config/../vendor/rails/railties/lib/initializer.rb:113:in `run'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/../config/environment.rb:20
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/dispatch.cgi:3:in `require'
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] \tfrom /var/www/redmine/public/dispatch.cgi:3
[Sun May 29 18:40:55 2011] [error] [client 98.210.156.61] Premature end of script headers: dispatch.cgi

I have RailsEnv production in my virtual host but it doesn't seem to work. If I do ./script/server -e production it works. Is there something I'm missing?

  • You have to decide whether you want to use passenger or CGI. The stack trace indicates the CGI variant. See the documentation on modrails.com on how to properly setup passenger. – Holger Just May 30 '11 at 15:20
  • Yeah, I had accidentally used cgi and passenger which caused errors later :) – Nicklas A. May 30 '11 at 16:38
1

The first problem was a permission problem. Solved by doing chmod -R a+rx /usr/lib/ruby

The second problem was that passenger wasn't running, I had a typo in my passenger.conf

0

Try this workaround: http://www.redmine.org/issues/7796#note-15

  • I've tried that already, sadly it does not work. This is what led me to believe it's a path issue. – Nicklas A. May 29 '11 at 4:49
  • Please give us the output of gem env? Did you check the rubys directory in the GEM PATHS to make sure the i18n-0.4.2 exist? – quanta May 29 '11 at 5:25
  • Turns out it was a permission problem, only root could read those gems. – Nicklas A. May 29 '11 at 16:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.