1

I'm trying to install Fedora 15 using the KVM VNC console. I can create the virtual machine just fine and can connect to the VNC console. A bunch of text scrolls by and then it hangs. I presume this is where the installer would be switching to the GUI but the VNC console can't cope.

How can I either convince VNC to switch the the graphical view or force the installer to be text-only?

For the latter, I have tried adding the "text" kernel option when I boot the VM, but it still hangs at the same place.

The host OS is Ubuntu 10 LTS.

Edit

Fedora will be running in a headless, text-only mode. I won't be using its GUI when it's running. In other words, this is for a server installation. I know FC can run in less than 1GB because I run one on a Linode with just 512MB.

Edit

Solution to the installer problem: boost the amount of memory to at least 768MB. It runs much better. After the installation was complete, I was able to reduce the memory footprint to 384MB and could go even lower if I wanted.

1

How much RAM do you have in your VM? F15 installer is comfortable at about 1GB.

Gnome-shell uses video acceleration for its functionality, but from what I read in this release there's a fail-back mechanism for environments that don't provide hardware acceleration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.