On a Windows 7 (x64) remote desktop session to a Windows 2003 SBS server I changed the password for the Domain administrator. After changing the password I tried to login as Administrator on the win2k3 Server using the attached console ( This login fails with a bad password error. The same password can be used to login without error when re-logging in using remote desktop.

I do not believe I was logged in when the password was changed, and an actual power down of the server did not resolve the problem and access to the command console is unavailable.

The state of the caps key has been checked many times. The keyboard on the Win7x64 machine is very different becuase it is a multilingual Laptop computer but the keyboard is set to US. The keyboard on the Win2k3SBS is also set to US. Both units are setup for Canadian English. A login using a Vista Machine via RWW works without a problem. The keyboard on the Vista Machine is close to the Keyboard on the Server.

Could it be a problem with the 64 bit version of the the Windows 7 system versus the 32 bit version of the Win2k3SBS R2?

To solve the problem the PW on the Windows-7 laptop was changed to all lowercase characters and numbers. I then logged out of the laptop. After this change I was able to login to Win2k3SBS and change the temporary PW to the required PW. I then logged out of the console of the Win2k3SBS. After login out of the Win2k3SBS I was able to use RDP on the laptop to login to Win2k3SBS.

  • Your question isn't very clear. Can you rephrase it? – joeqwerty May 30 '11 at 17:10
  • @Vescovo - I see through the pending edits that you've found an answer to your question. Can you please post your solution as an answer, and then "accept" it, so that others who come by will see it as the solution. – Mark Henderson May 30 '11 at 22:46
  • I have posted it. It was pending for review? – Vescovo May 30 '11 at 23:50

Was the console session logged in when you changed the password for the logged in user (Administrator)? If so, then log in using the old password, log out, and log back in with the new password.

  • After additional testing to make sure both the Local and RDP logins work I think it can be concluded that this may have been the source of the problem. – Vescovo May 30 '11 at 23:48
  • Glad to help... – joeqwerty May 31 '11 at 1:05

Your question was not 100% clear, but if I understand your problem right, try going to HKEY_CURRENT_USER\Software\Microsoft\Terminal Server Client\Servers and deleting the server you are having trouble with. Then try RDP again, and hopefully that will work then.

  • If that works for you, please come back and mark it as answered (click on the check mark). – KCotreau May 30 '11 at 17:13

Have you tried the obvious thing and toggled caps lock? I've had weirdness before where the indicator on the keyboard was showing the opposite to what it really was (i.e the caps lock light was on, but caps lock was off).

How about keyboard layout? Have you got a different keyboard layout on the local console than you do on the Windows 7 machine? If for example one is en-gb and the other is en-us, what is @ on a UK keyboard will be " on a US keyboard. You may have inadvertantly set the password to contain a special character which is on a different key to the one you expect, depending on the keyboard layout.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.