I have a Ubuntu 9.04 server which has no packase support anymore. If I want to update my package lists, I get th following errors:

 Err http://de.archive.ubuntu.com jaunty-security/multiverse Packages
   404 Not Found [IP: 80]
 W: Failed to fetch http://de.archive.ubuntu.com/ubuntu/dists/jaunty/main/binary-amd64/Packages  404 Not Found [IP: 80]

I read at the official Ubuntu-Support-Page, that there is a update-manager-core-Package to upgrade to a new release. Unfortunately I dont have this package installed and I am unable to install it because of the lack of package sources.

EDIT: Installing the package update-manager-core from another release doesn't work because it depends on a higher version of python-apt. (Tried with 10.04)

 $ dpkg -i update-manager-core_0.134.7_amd64.deb
 Selecting previously deselected package update-manager-core.
 (Reading database ... 28743 files and directories currently installed.)
 Unpacking update-manager-core (from update-manager-core_0.134.7_amd64.deb) ...
 dpkg: dependency problems prevent configuration of update-manager-core:
  update-manager-core depends on python-apt (>=; however:
   Version of python-apt on system is 0.7.9~exp2ubuntu10.
  update-manager-core depends on python-gnupginterface; however:
   Package python-gnupginterface is not installed.
 dpkg: error processing update-manager-core (--install):
  dependency problems - leaving unconfigured
 Errors were encountered while processing:

So, whats the best way to upgrade to to current Release without reinstalling the complete (virtual) server?

  • what if you get the update-manager-core deb file from another version (for example from 10.04)? url: packages.ubuntu.com/lucid/update-manager-core – Jure1873 Jun 1 '11 at 13:48
  • Does do-release-upgrade depend on the package lists, too? – Shane Madden Jun 1 '11 at 20:19
  • I've tried it, but it depends on a higher version of python (see my edit) – Fu86 Jun 1 '11 at 22:54
  • 1
    This thread saved my ass today. And since I don't have enough reputation to upvote, I'd like to say thank you here! – Michalis Polakis Jan 18 '12 at 12:57

I've solved the problem myself.

Download the ISO-File and mount it in a local folder:

 wget http://old-releases.ubuntu.com/releases/jaunty/ubuntu-9.04-server-amd64.iso 
 mkdir cdrom
 mount -o loop ubuntu-9.04-server-amd64.iso

Adjust the /etc/apt/sources.list and add the local folder

 deb file:///tmp/cdrom/ main

Perform an update and install update-manager-core

 apt-get update
 apt-get install update-manager-core

Now a System update from 9.04 to 9.10 and then from 9.10 to 10.04 LTS works fine!

|improve this answer|||||

If you are useing virtulization that /dev/loop# might be unpremited to use (security reasons), however the DEB file is still on the jaunty cd so if you can mount it locally you can upload it to your server and run dpkg -i update_manager_whatever.deb for the same result.

The file is in pool/u/update-manager

|improve this answer|||||

I had a similar issue starting at 9.10. Thanks greatly to Fu86. I had to make some slight modifications due to errors I encountered, but the information provided was very helpful.

cd /tmp
wget http://old-releases.ubuntu.com/releases/karmic/ubuntu-9.10-server-amd64.iso
mkdir cdrom

Mounting the image using Fu86's method gave me

mount: can't find ubuntu-9.10-server-amd64.iso in /etc/fstab or /etc/mtab

However this worked as desired:

sudo mount -o loop -t iso9660 ubuntu-9.10-server-amd64.iso /tmp/cdrom

Edit the /etc/apt/sources.list file adding the directory on the mounted iso. I had to do this a little differently so as not to get an error about a "Malformed [...] dist parse". In the following command karmic is the directory inside the dists directory within cdrom and main is the directory within that:

deb file:///tmp/cdrom/ karmic main

Finally I ran:

sudo apt-get update
sudo apt-get install update-manager-core
sudo do-release-upgrade

Good luck and thanks again to Fu86 for most of this info.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.