1

We have a webpage (vimity.com) in php served by Apache on top of Ubuntu 9.04. The homepage looks great on FF and Safari but not on Chrome. The problem with Chrome is only on the Homepage, the rest of the page is looking good on all browsers. When we disable the cache the problem does not appear and Homepage looks also good on Chrome.

On the logs I couldn't find anything strange, I see the request in the access log but nothing on the error log.

Another thing we noticed is that if we disable the app cache (stored in files using Cache_Lite) the homepage works fine but if we activate it again it stops working, that's weird because on staging works perfect and the servers/configs/code are the same.

If you take a look at the chrome console you'll see a line that says "GET http://www.vimity.com/ 200 (OK)" but in red, also in the resources tab, near the html you'll se a red circle with the number one inside (like a syntax error or something) but nothing else, no errors, nothing.

Any ideas?

Thanks in advance


Software versions

  • PHP 5.2.6-3ubuntu4.5 with Suhosin-Patch 0.9.6.2
  • Apache/2.2.11
  • Ubuntu 9.04
  • MySQL 5.0.75-0ubuntu10.2

Installed PEAR packages

  • Archive_Tar 1.3.2
  • Cache_Lite 1.7.11
  • Console_Getopt 1.2.3
  • Fileinfo 1.0.4
  • HTTP_Request2 2.0.0RC1
  • Net_URL2 0.3.1
  • PEAR 1.7.1
  • Services_GeoNames 1.0.1
  • Structures_Graph 1.0.2
0

It seems that the Content-Length header is wrong, as if its getting interrupted from the connection.

If you're setting Content-Length somewhere in PHP for use with your cache, I would start by looking at debugging this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.