So here's the deal, I am trying to automate this load test using VM's and WinTask. So I'm writing a script using psexec that will kick off another script on each VM that will kick of WinTask and that is how I will get concurrent users for this test. Well I keep getting Access is Denied errors with this script. I've researched this problem and I've tried everything I can think.

This was my latest attempt:

psexec \\ipaddress -u administrator -p password -d -h -i -s cmd.exe /c start C:\Users\Administrator\Desktop\runtest.exe

I opened credential manager and tried that, I've turned off the firewall on both computers, I've tried every -<> and still Access is Denied. Any suggestions?

EDIT: Also I can ping, RDP from machine A-B and B-A, everything network wise is connected, its only when I try to use this psexec it wont run it

EDIT: Tried using the computer name instead of the IP address and I got a little bit different error, Couldn't install PsExec service: Access is denied So still access is denied error


As a test, switch the command to ipconfig instead of cmd.exe.

Are you on a domain? If so the username should be in the form domain\username.

I would try to match the following example (substituting the proper IP address, domain, username, and password):

psexec \\IP_Address -u domain\username -p password ipconfig
| improve this answer | |

UAC or other issues? You are running Windows 7, and to get a lot of this stuff working I heavily tweaked machines over the first few months of my first job. You might need to do the same. Not sure if that is the real reason, but just saying it is likely.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.