I've got a windows 2008 R2 domain here in my office, fully featured with user groups, and user permissions. These permissions, folders, etc work fine. The problem is, some of my users are now being upgraded to Windows 7, i join our domain, and they're able to log in, see servers, access the internet, etc. The problem is, when they access their "private" folders, that they have permissions for, they're unable to write, only read. I double check the permissions, and they have full access rights.

Let me be clear, they're logged into the same active directory account they were on XP, just now on their new Win 7 set up.

Has anyone had similar issues, or know more than I do about the connection between servers and Windows 7? Everything was working fine for them until these users moved to Win 7.

The Error says:


You need permission to perform this action.

You require permission from OCC\Judith.Wilkins to make changes to this file.


She's logged into the domain.

This is what the event log says, an Audit Failure :

A network share object was checked to see whether client can be granted desired access.

Subject: Security ID: OCC\Judith.Wilkins Account Name: Judith.Wilkins Account Domain: OCC Logon ID: 0xb8a7f1

Network Information:
Object Type: File Source Address: Source Port: 65174

Share Information: Share Name: \*\OKCCWQ Share Path: \??\E:\OKCCWQ Relative Target Name: WQ_DIR\WQ_FILES\Users\JudithW\Public\To Do List.doc

Access Request Information: Access Mask: 0xe0080 Accesses: READ_CONTROL WRITE_DAC WRITE_OWNER ReadAttributes

Access Check Results: READ_CONTROL: Granted by D:(A;;0x1200a9;;;BU) WRITE_DAC: Not granted WRITE_OWNER: Not granted ReadAttributes: Granted by D:(A;;0x1200a9;;;BU)

I'd appreciate any advice or help.

  • 1
    Which version of windows 7 is this? Is the mapped drive done with GPO, login script, or Active Directory Home Location? Any errors in either event log on the server or on the workstation? – Nixphoe Jun 9 '11 at 18:41
  • Windows Professional, mapped through windows "map network drive" command, although going straight to the folder location through windows explorer does the same thing. There are several of these errors under Security on event viewer. It's too long to post here, so here is it in a text file. dl.dropbox.com/u/47944/Security%20Log%20Judith.txt – Funran Jun 9 '11 at 18:54
  • 1
    Just for clarification you have had server 2008r2 with xp clients and when you upgraded to windows 7 the clients cant access shares. Are the shares new or have the users been able to access these shares when they where running xp? Also you mention their "private files" are you using roaming profiles? or file redirection? I believe when a user logs in from xp its Profiles/username and in 7 its Profiles/username.v2 when using roaming profiles. Could this be an issue? Let me know thanks – Branden Jun 10 '11 at 0:27
  • The users are accessing a shared folder on the network, and accessing files they have permission to. The example in my error log (posted above), she's trying to rename a file in a folder she has write permissions for. She's denied with an error telling her to get permission from...herself. I'm not sure the difference between xp and 7's username/profiles, but it's different enough that the server doesnt think she is who she says she is. She belongs to the domain, she's logged in to the domain. I just don't get it. – Funran Jun 10 '11 at 15:26

OK Internet world,

I've solved my own problem, and as most IT problems - it was easy, as well as obvious.

Just to recap - my users are on XP and 7, those on XP can write/read their folders fine, but those users who are upgraded can't access folders they have AD permissions for. I noticed that another folder (for a different building) had users on Win 7 that were NOT having write issues, so I compared them. Security settings were both the same, but SHARING settings were different. The folder that worked at Change/Read selected, and the one I'm having problems with only had Read selected.

simple conflict.

What was so challenging about this is the fact that it still works for XP users, but not 7. I guess XP doesn't care if the folder is shared with read and change as long as the folder in question has security permissions for that user that let them write.

I want to thank everyone for trying so hard to help me out, and hope someone in the future stumbles across this thread and saves a week of stress from their IT lives.

Lesson to us all, it's probably something simple.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.