0

The following messages are dumped into the server logs endlessly. This limits the usefulness of logwatch. Is there a way to fix whatever the issue is or to turn off these messages? Reducing the log level in smb.conf does not seem to reduce these messages:

Jun 9 14:28:37 xxx nmbd[5627]: Unable to find the Domain Master Browser name MYGROUP<1b> +for the workgroup MYGROUP. Jun 9 14:28:37 xxx nmbd[5627]: Unable to sync browse lists in this workgroup. Jun 9 14:43:37 xxy nmbd[5627]: [2011/06/09 14:41:08, 0] +nmbd/nmbd_browsesync.c:350(find_domain_master_name_query_fail)

0

Aside from the obvious answer of: fix the issue and stop the logging :)

You could use a dirty hack to have syslog write to a fifo (see mkfifo(1)) and have some program read from that fifo and write to your log file, but that's a real dirty hack.

This one is a dirty hack, but less of a one. I hate a daemon running like that in the background reading from a fifo. I'd use syslog-ng instead of the standard syslog (probably rsyslog) that you're using.

syslog-ng is a bit more of a learning curve, but worth it really. A directive something like:

destination samba-log { program "/usr/local/bin/samba-ignore.sh"; };

Then write a small shell script /usr/local/bin/samba-ignore.sh to read from STDIN and ignore (i.e. grep -v) out the lines you want and output to /var/log/samba.log or similar.

Personally I'd do everything in my power to stop it logging that particular issue, including going to the source and figuring out what is wrong up to and including rolling my own RPM with a fix. But I'm OCD like that ;)

0

This link [http://lists.samba.org/archive/samba/2001-April/026763.html] suggests setting local master and preferred master to yes to end this message, however these are already set in smb.conf.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.