I am having trouble backing up my server. I back up to an external hard drive, and up until now, I haven't had any problems with it. But today my backup failed. Here is the report from the backup log:

   Backup Status
Operation: Backup
Active backup destination: File
Media name: "Backup 2011-06-09.bkf created 6/9/2011 at 3:02 PM"

Volume shadow copy creation: Attempt 1.
Timeout before function completed

Error returned while creating the volume shadow copy:0xffffffff.

Error returned while creating the volume shadow copy:ffffffff
Aborting Backup.


The operation did not successfully complete.

Has anyone seen this error before? What is a 'volume shadow copy'?

3 Answers 3


A Volume Shadow Copy is basically a way of ensuring that your backup image is consistent and any files that are locked (for example a spreadsheet you have open in Excel) can still be backed up.

The VSS writer can fail in many ways and the error message you receive usually gives you a fair clue as to what the problem might be. In your case, it seems the system waited an unusually long amount of time for Windows to create a consistent snapshot of the filesystem and aborted with this error because it took longer that it should.

Because all I/O operations are suspended while the shadow copy is created, the system is actually only given 10 seconds to create a consistent snapshot or the shadow copy creation will fail.

Firstly I'd simply try the backup again. I've personally seen it throw this error before and literally 30 seconds later when I tried again it was fine.

Perhaps the system was simply overloaded and the VSS snapshot timed out because the system couldn't keep up with the workload. Maybe there is a hardware problem that is causing this error (probably hard disks if anything), however I'd expect other things to be going wrong than just this.

Your Windows Event Log may contain some extra details relating to the problem, and that would be my next port of call. Check any events around the time the backup started and see if any are relevant.

Bonus reading: This blog post from someone on the file server team at Microsoft is quite interesting and explains the whole process and history quite well.


Most of the time I've seen this happen when running 32 bit sql server on 64 bit windows, another reason is crappy antivirus software. If the AV softwaer doesn't run quick enough the vss writers don't have time to complete and abort. You shold also look in the event log for errors. This blog post can help determine some things to look for.


I was receiving the same error and after following various posts, registering dll's and the like, none of which resolved the problem. I eventually found the following error in event viewer: Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80070057. this lead me to the following kb article which resolved the problem; http://support.microsoft.com/kb/2009533

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .