I have a Dell PE 1850 that I am trying to get RAID setup on. During boot the system sees two hard drives at HBA 0 and 1 but then when it prompts me for Raid setup press Ctl-M and I do and enter the Perc setup I do not see any physical drives. How am suppose to setup a logical Raid drive? If go to install windows server I see the two drives separately.


As suggested grab the drivers you need from the Dell support site for 1850s. You can try for individual drivers or just grab the SUU/Server Update under systems management- this has the whole repository of drivers for your system (just select your OS from the drop-down). Also here is a nice walkthrough on creating the RAID. If you see them in Windows setup then you should be able to see them in RAID configuration. If CTRL-M isn't working you can also try to run the System Configuration disk, also under systems management. This allows you to apply updates from repository, configure your raid, and copy Windows Preinstall files to the system.

  • More info: I tried using CentOS live CD to do the update and the package said the update was not applicable to this system. Also when I tried installing Windows Server 2008 and tried to load the Perc drivers Windows said not hardware not found or something so it leads me to believe that the system is not able to view the SCSI controller card. – Garfield81 Jun 15 '11 at 17:45
  • I had problems trying to get 2K8 to see my 1850 RAID setup as well but that may be fixed now (I tried that a while back). Your 1850 may still have the 3.5" floppy... you could always try getting the PERC on that way (.exe). I have only used the CentOS live CD to apply Dell patches to VMware hosts when they are stubborn. Did you try downloading/running the SUU? – Chadddada Jun 15 '11 at 17:53
  • Thanks Chadddada. Is the SUU a bootable CD or would I have to install an OS first to be able to use SUU – Garfield81 Jun 15 '11 at 18:32
  • It should be bootable. If it doesn't boot for you then you can always run the Systems Management and then select the 3rd option down, firmware update. This will then allow you to select your SUU disk as the repository of drivers. When you push the whole build through it will install the firmware from the SUU repository. – Chadddada Jun 16 '11 at 15:59
  • Update: I went through the whole Windows 2008 installation on one of the hard drives and downloaded the PERC update utility for Windows. When I ran the utility it said it was not compatible with my system or something along those lines. So looks like the hard drives and perc card are disconnected somewhere. – Garfield81 Jun 17 '11 at 1:33

You should definitely use the Perc card setup (ctl-M) at boot time. Try updating the perc firmware. That may help recognize the drives.

  • Ok but having a hard time updating PeRC firmware without a floppy drive. Tried CentOS live CD with no luck – Garfield81 Jun 14 '11 at 22:17
  • Search the web for HP's USB formatting utility that allows you to create a bootable DOS USB. Pop the firmware update on that and boot/upgrade from there. Remember to alter the BIOs boot order and/or enable USB booting if not already enabled. – Asinine Monkey Jun 14 '11 at 22:43
  • Asinine Monkey said HP, but Dell also has utilities that can be burned to DVD to update firmware system-wide. If you have problems, or don't want to waste time, just call their support line if you are covered. On second thought, they can walk you through the whole thing, including the RAID setup after they help you fix your initial problem. – KCotreau Jun 14 '11 at 22:52
  • THanks KCotreau but I believe the system is out of warranty. Would you mind sending me the link to the DVD. – Garfield81 Jun 15 '11 at 17:45
  • THanks KCotreau but I believe the system is out of warranty. Would you mind sending me the link to the DVD. – Garfield81 Jun 15 '11 at 17:46

Turns out to be an issue with the hardware somewhere. Returning/replacing the hardware. Thank you all for your answers and suggestions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.