We have a problem with the network card on a Dell Power Edge R410 with Debian 6 (squeeze). It seems that the network card went into "sleep" mode after some time. If we are connected via ssh to the server, the connection drops after a certain period of inactivity. If we then ping the server, it doesn't answer to the first packets, but after 5-10 seconds it's answering again.

Here are the configuration details:


2.6.32-5-amd64 #1 SMP Wed May 18 23:13:22 UTC 2011 x86_64 GNU/Linux

NIC Driver:

Broadcom Corporation NetXtreme II BCM5716 Gigabit Ethernet bnx2 v2.6.29-11:26
driver: bnx2
version: 2.0.2
firmware-version: 5.0.11 NCSI 2.0.5
bus-info: 0000:01:00.0

UPDATE: I'm not sure, but maybe not only the network card but the whole server went to sleep mode. I can't see anything in /var/log/messages when it happends, if someone knows haw I can increase the loglevel to see more let me know.

  • Do all your computers in your network have unique IP numbers? – bmk Jun 15 '11 at 10:10
  • Yes, we can be sure that we use unique IPs. We had OpenSuse installed before with the same IP adresses where we didn't have that problem. – markus Jun 15 '11 at 11:45
  • Can you post a packet dump from affected machine and from a remote machine? – Mircea Vutcovici Jun 15 '11 at 11:50
  • @Mircea: How exactly would you perform such a dump (especially on a busy server), and what could you read from it? – Chris Lercher Jun 15 '11 at 12:34
  • @Chris Lercher: you can use one of tcpdump, dumpcap or tshark – Mircea Vutcovici Jun 16 '11 at 18:20

Not an expert on either Linux, but perhaps its related to power settings?

Most servers/OSs have settings to control power consumption and they can turn off or put to sleep some hardware components if they're idle for some time. Perhaps squeeze is configured by default to allow the NIC to go to sleep, or maybe this setting is configured in the BIOS of the server and the OS just doesn't override it.

Check the settings in the BIOS and OS. In the BIOS it should be under POWER.

  • I disabled all acpi stuff, but the problem is still there. I put a cron job which pings every 20 minutes 5 times the server. Sometimes it is not answering directly. I startet tshark on the server capturing imcp packages, let's see if the server receives the pings ... – markus Oct 13 '11 at 22:49

You should check if the problem is on the server or in your network.

Are you connecting to this server from the same IP subnet where it resides or from another one?

What do you see if you start a network sniffer (such as WireShark) on the server after a connection drops and then try to ping it from another computer?

  • We worked arround the problem by installing Open Suse. There the problem does not appear. Today we again installed Debian squeeze on a Dell Power Edge R410, we still se that problem. The problem seems to be Debian specific ... – markus Oct 12 '11 at 9:57

Finally I solved the issue. After upgrading the bnx2 network driver to version 2.0.23b the problem is solved.


I believe the problem was caused by the one described http://comments.gmane.org/gmane.linux.hardware.dell.poweredge/38721

  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Scott Pack Nov 5 '12 at 21:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.