1

(I'm not sure this is the best place to ask this question, so if not, please redirect me to it)

I'm setting up a new win2008R2 terminal server and am having issues with an application that runs fine on our 2003 TS. If I run the application as a regular user I get the following error:

Component 'MSComm32.ocx' or one of its dependencies is not correctly registered: a file is missing of invalid.

If I run the application as administrator, it runs fine.

I tried downloading MSComm32.ocx and registering it with regsvr32 (as admin) but without any luck.

How do I know what the dependencies are?

Thanks.

2
  • Where is the file located? Commented Jun 15, 2011 at 13:24
  • I downloaded it and put it in the c:\windows\system32 folder. Commented Jun 17, 2011 at 7:45

1 Answer 1

1

Try unregistering the ocx file, move it to the syswow64 folder and then register it. Strange as it might seem, that oddly named folder is where 32 bit libraries go on a 64 bit Windows machine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .