1

Struggling a bit trying to work this out. I'm on a Centos 5.5 VPS with multiple IP addresses.

I've setup the IP address alias for eth0 (eth0, eth0:1, eth0:2, eth0:3, eth0:4, eth0:5), each with a different static address, using the Red Hat Text Mode Setup Utility (setup).

I've saved the config and rebooted but only eth0 and eth0:5 show up with ifconfig.

The folder /etc/sysconfig/networking/devices shows all interfaces scripts

but /etc/sysconfig/network-scripts/ only has ifcfg-eth0 and ifcfg-eth0:5 (which is what ifconfig seems to find).

Do I need to do anything else to make those aliases show up?

Thanks

1

As far as I know, you DO need the relevant scripts in /etcsysconfig/network-scripts. The easiest is probably to just copy the script ifcfg-eth0:5, rename and adjust the settings as appropriate, then restart networking (no need to reboot the server).

  • Thanks, wasn't just that - i think plesk was playing some role here. After adding those ips to plesk and restarting the network it worked again. Thanks for helping though! – Ben Jun 16 '11 at 9:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.