Does anyone know the command that enables the usage of 3rd party SFP+ on an Arista 7148S switch?

2 Answers 2

  1. Login as admin;
  2. Enable privileged access;
  3. Go to the bash shell;
  4. Touch the filename /mnt/flash/enable3px;
  5. Reboot the switch.

Below is a session from EOS-4.11.6:

localhost login: admin

Arista Networks EOS shell

[admin@localhost ~]$ touch /mnt/flash/enable3px
[admin@localhost ~]$ sudo reboot
  • According to an anonymous user... this is either false or not applicable to most arista switches. this command does not exist on the /mnt/flash directory on 7124s, and is likely a troll. Oct 5, 2012 at 20:57
  • According to a 1 rep user... bash: /mnt/flash/enable3px: No such file or directory Oct 5, 2012 at 20:58
  • Interesting :) I'm not sure. I don't have access to Arista anymore.
    – ewwhite
    Nov 5, 2012 at 16:43
  • 1
    Seems I can't comment yet, so this is confirming @waszkiewicz answer worked for us. We just received a new 7150s. Using the Finisar SFP+ modules we had in stock produced "errdisabled xcvr-unsupported." Using the commands above, we are now up and running. "connected a-full a-1G 1000BASE-T" EOS-4.14.1F.swi Just saw the rest of the question was for a EOL 7148S. We have a 7150S, so ymmv.
    – chaddow
    Oct 16, 2014 at 15:20
  • 1
    This worked for me today on an Arista 7148. Thanks. Oct 22, 2014 at 17:20

The enable3px file is a dummy file. You can create a 0kb txt and rename it "enable3px" and it will work all the same. Hope this helps.

This method seems to have been disabled per arista EOS 11.3

  • Just worked on 4.12.7 for me.
    – X-Istence
    Nov 16, 2015 at 21:49

Not the answer you're looking for? Browse other questions tagged or ask your own question.