this is half a minute work with any firewall, but with the built-in firewall on Windows 2008 R2, I am stuck here for half an hour.

I want to block all incoming ICMP requests to my server, EXCEPT those IP addresses that I want. My firewall policy is to "Block all inbound requests that do not satisfy a rule"

1st attempt: I create an allow rule for only those IPs that I want. The firewall should allow only those and block all others. Result: It allows everything.

2nd attempt I create a Block rule for ICMP and for Any IP. Then I keep the same Allow rule as in 1st attempt. Result: It blocks everything.

What am I missing here ?


OK. I give up. The only thing that I can do is to Block all addresses using as scope those ranges that leave out all the IPs that I want to be allowed.

For example if I want to allow IP is set the scope:

  1. from to
  2. from to

I wish there was another way.

  • 2
    Block ICMP echo if you really must (it won't secure your systems BTW!), but I'd suggest you don't block all ICMP packets. – Bryan Jun 17 '11 at 17:05
  • Thanks for the suggestion Bryan. However this does not answer my question – Theo Zographos Jun 17 '11 at 18:26
  • exactly why I posted it as a comment rather than an answer :) – Bryan Jun 17 '11 at 21:03

No need to create a rule from scratch. There should be a rule called File and Printer Sharing (ICMPv4). Enable this and lock down to IPs you want.

EDIT: Make sure that you edit the correct version of firewall. I.E. Domain, if you connected to a domain etc.

  • nope. everyone can connect, even though I restricted to the IPs that I wanted. – Theo Zographos Jun 17 '11 at 17:04
  • 1
    That means that there is another rule that is enabled that is overriding your denies. Allows trump denies in the 2008 firewall. – Tatas Jun 17 '11 at 19:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.