2

I have setup SQL Server express R2 on WIndows Server 2008 R2 and i can connect locally with SQL Management studio.

Remotely with the firewall enabled i cannot connect.

If i disable the firewall then remotely i can connect.

THis is very strange.

My firewall setting is set to TCP 1433 (although i also added 1434 as well)... but it refuses to work.

In the SQL Express R2 i have TCP/IP Enabled and it listens on 1433

Any help really appreciated, i am little lost. I have searched the net and i believe i am doing everything correctly.

Thanks in advance

3
  • Do you have the permissions to connect both sql server to and database?
    – Turdie
    Jun 17, 2011 at 21:23
  • well if i disable the firewall i can connect without an issue. I am using sa ... infact i am using the exact same settings... all i do is disable the firewall and it works ... enable the firewall and it won't let me through.
    – Martin
    Jun 17, 2011 at 21:43
  • This brings an assumption that there may be a rule that actually denies SQL port (could be named "Block MSDE", for example). I assume is it Windows Firewall not 3rd party? Maybe (just maybe) the rule that enabled SQL Server port is enabled only to certain Profile?
    – LazyOne
    Jun 17, 2011 at 22:11

2 Answers 2

1

Have you restarted the SQL service since you made the configuration changes to enable TCP/IP and set a static port? These changes will not take effect until the service is restarted.

You can verify what ports are being listened on by using netstat -a on the server.

1

Add these ports:

TCP 1433, 1434, 1444 UDP 1434

To be honest, I don't remember how I found these, or if I had to do anything to SQL (I don't think I did), but I took these from a SonicWALL I set up to do just what you are trying to accomplish, and it works.

Make sure you do it on both the hardware firewall and local software firewall.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .