3

I have a newly built ESXi server with two SSD's hooked up to the motherboard primary SATA controller. Everything was working until I made the mistake of enabling passthrough on that SATA controller. Now, ESXi will reboot & come up complaining it doesn't have any data stores configured:

enter image description here

Each time I'll go in & uncheck passthrough for that controller & reboot again, but it keeps coming back up enabled. Not sure what to do from here?

I tried temporarily disabling VT-d in BIOS, but that didn't help. Passthrough showed disabled in ESXi, but I still got the persistent storage error.

5

Why not just reinstall, which would reset the configuration.

  • Probably what I'll have to do. – churnd Jun 19 '11 at 13:13
  • I re-installed. – churnd Mar 2 '12 at 11:16
2

Assuming you don't expect any data to still exist on the SSD drives, disable VT-D, reboot and create a new datastore in the storage tab on the SSD's. That would become your "persistent storage".

  • One of the SSD's is the ESXi boot disk. – churnd Jun 19 '11 at 3:51
0

I have a similar problem where I have three M.2 PCIE SSD's and enabled the wrong two for Passthrough (PCIE numbering seems to be opposite from what I thought it would be. It loses al changes after reboot, so you can't undo this anymore. Will try to boot ESXi from a USB stick, so I safely can move my VM's on that datastore to a NAS. Then I can probably reinstall ESXi and enable the right SSD's for Passthrough.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.