1

I have a xen guest machine running ubuntu 10.04 with a disk device marked as read only.

Now if while the xen guest is running I mark the device as read-write how can I tell the guest it can now write to it?

The obvious mount -o rw doesn't work it still says it's write protected. Restarting udev doesn't do anything, I also tried hdparm -r 0 /dev/xvdd then remounting which appears to work until the device is unmounted and remounted which then causes all written data to disappear.

Anyone know how to achieve this without rebooting the guest?

0

Try using the remount option with the mount command as in mount -o remount,rw /dev/xvdd. An example using ro can be found in /etc/init.d/umountroot.

Some virtual file systems write their changes to a separate files allowing multiple virtual servers to use one file as the base file system. Persistence options for the file system alter what happens when the virtual server is restarted.

2
  • using the mount command doesn't work, already tried that, it does appear a reboot is required due to your virtual file system comment. – Rwky Jun 21 '11 at 15:54
  • If the virtual device doesn't support persistent writes, then I would expect a reboot to be required. – BillThor Jun 22 '11 at 1:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.